summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRubenKelevra2023-03-24 02:49:34 +0100
committerRubenKelevra2023-03-24 02:50:36 +0100
commita7539fc7f68a02e8666c0e3c64a00f6098b5dacd (patch)
tree6b9ed3d8e9813c80dd92dbe62f40167773d5e2c7
downloadaur-a7539fc7f68a02e8666c0e3c64a00f6098b5dacd.tar.gz
initial version
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD42
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..214fc0c85cb3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = python-platformio
+ pkgdesc = A professional collaborative platform for embedded development. Cross-platform IDE and Unified Debugger. Static Code Analyzer and Remote Unit Testing. Multi-platform and Multi-architecture Build System. Firmware File Explorer and Memory Inspection.
+ pkgver = 6.1.6
+ pkgrel = 1
+ url = https://platformio.org
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python
+ depends = python-bottle>=0.12
+ depends = python-click>=8.0.4
+ depends = python-colorama
+ depends = python-marshmallow>=3
+ depends = python-pyelftools>=0.27
+ depends = python-pyserial>=3.5
+ depends = python-requests>=2
+ depends = python-semantic-version>=2.10
+ depends = python-tabulate>=0.9
+ depends = python-aiofiles>=22.1
+ depends = python-ajsonrpc>=1
+ depends = python-starlette>=0.23
+ depends = uvicorn>=0.20
+ depends = python-wsproto>=1.2
+ source = https://files.pythonhosted.org/packages/source/p/platformio/platformio-6.1.6.tar.gz
+ b2sums = d8163775942cd780f8d2eb6d5c1109bb4771669d41e915772c4b1c14d9773ee5e17b9b03b8791328f63d6b1af1a0cca15dba3b5e7fef3eceb180073dd4437266
+
+pkgname = python-platformio
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58ddc25f54a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: @RubenKelevra <cyrond@gmail.com>
+
+pkgname='python-platformio'
+_module=${pkgname#python-}
+pkgver='6.1.6'
+pkgrel=1
+pkgdesc="A professional collaborative platform for embedded development. Cross-platform IDE and Unified Debugger. Static Code Analyzer and Remote Unit Testing. Multi-platform and Multi-architecture Build System. Firmware File Explorer and Memory Inspection."
+# IoT, Arduino, CMSIS, ESP-IDF, FreeRTOS, libOpenCM3, mbedOS, Pulp OS, SPL, STM32Cube, Zephyr RTOS, ARM, AVR, Espressif (ESP8266/ESP32), FPGA, MCS-51 (8051), MSP430, Nordic (nRF51/nRF52), NXP i.MX RT, PIC32, RISC-V, STMicroelectronics (STM8/STM32), Teensy
+url="https://platformio.org"
+depends=(
+ 'python'
+ 'python-bottle>=0.12'
+ 'python-click>=8.0.4'
+ 'python-colorama'
+ 'python-marshmallow>=3'
+ 'python-pyelftools>=0.27'
+ 'python-pyserial>=3.5'
+ 'python-requests>=2'
+ 'python-semantic-version>=2.10'
+ 'python-tabulate>=0.9'
+ 'python-aiofiles>=22.1'
+ 'python-ajsonrpc>=1'
+ 'python-starlette>=0.23'
+ 'uvicorn>=0.20'
+ 'python-wsproto>=1.2'
+)
+makedepends=('python-setuptools')
+license=('Apache')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+b2sums=('d8163775942cd780f8d2eb6d5c1109bb4771669d41e915772c4b1c14d9773ee5e17b9b03b8791328f63d6b1af1a0cca15dba3b5e7fef3eceb180073dd4437266')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/python-platformio/LICENSE"
+ python setup.py install --root="${pkgdir}" --optimize=2 --skip-build
+}