summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsaac Freund2020-03-08 22:38:59 -0500
committerIsaac Freund2020-03-08 22:38:59 -0500
commita758dcbba38cdfa5d1edb7733c7af69d933a8096 (patch)
tree7bc7e3b1941a4c6bcec00b5bca4b87241be7b3bc
parent423508519e200cd55f9a2b35b04296aae1367e16 (diff)
downloadaur-a758dcbba38cdfa5d1edb7733c7af69d933a8096.tar.gz
upgpkg: bonsai.sh-git r84.6c3812b-2
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD43
2 files changed, 25 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09e87593ba3f..718137c9d1e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = bonsai.sh-git
- pkgdesc = A randomly generated bonsai tree in your terminal!
- pkgver = r43.0c43085
- pkgrel = 1
+ pkgdesc = bonsai tree generator written in bash
+ pkgver = r84.6c3812b
+ pkgrel = 2
url = https://gitlab.com/jallbrit/bonsai.sh
arch = any
license = GPL3
makedepends = git
depends = bash
- source = bonsai.sh-git::git+https://gitlab.com/jallbrit/bonsai.sh.git
+ depends = bc
+ provides = bonsai.sh
+ conflicts = bonsai.sh
+ source = bonsai.sh::git+https://gitlab.com/jallbrit/bonsai.sh.git
md5sums = SKIP
pkgname = bonsai.sh-git
diff --git a/PKGBUILD b/PKGBUILD
index a7e11eb589a6..53efabcb90c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,27 @@
-# Maintainer: N.E. Neal <contact at [part of name before neal without dots] dog com>
-pkgname='bonsai.sh-git'
-pkgver=r43.0c43085
-pkgrel=1
-pkgdesc="A randomly generated bonsai tree in your terminal!"
+# Maintainer: Isaac Freund <ifreund@ifreund.xyz>
+# Contributor: N.E. Neal <contact at [part of name before neal without dots] dog com>
+
+_pkgname='bonsai.sh'
+pkgname="${_pkgname}-git"
+pkgver=r84.6c3812b
+pkgrel=2
+pkgdesc='bonsai tree generator written in bash'
arch=('any')
-url="https://gitlab.com/jallbrit/bonsai.sh"
+url="https://gitlab.com/jallbrit/${_pkgname}"
license=('GPL3')
-groups=()
-depends=("bash")
-makedepends=("git")
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("${pkgname}::git+https://gitlab.com/jallbrit/bonsai.sh.git")
-noextract=()
+depends=('bash' 'bc')
+makedepends=('git')
+provides=('bonsai.sh')
+conflicts=('bonsai.sh')
+source=("${_pkgname}::git+${url}.git")
md5sums=(SKIP)
pkgver() {
- cd $startdir/$pkgname
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd ${srcdir}/${pkgname}
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm755 bonsai.sh "$pkgdir/usr/bin/bonsai.sh"
- sudo ln -s /bin/bonsai.sh /bin/bonsai
+ cd "${srcdir}/${_pkgname}"
+ install -vDm 755 bonsai.sh -t "${pkgdir}/usr/bin/"
}