aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAsukaMinato2023-10-29 08:23:50 +0900
committerAsukaMinato2023-10-29 08:23:50 +0900
commita79b1d23b0000b7831293bf846096ca477acde75 (patch)
treeb5fda575d0bde6390d2e145b342f62750d3f0bf6
parent1439c9d3c740925d82db27891b4822979f30e990 (diff)
downloadaur-a79b1d23b0000b7831293bf846096ca477acde75.tar.gz
update
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
-rwxr-xr-xgen.sh88
-rwxr-xr-xrun.sh2
4 files changed, 13 insertions, 98 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2bcf9cd63bc5..6cd1db5c0d91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = deepin-wine-tim
pkgdesc = Tencent TIM on Deepin Wine5(com.qq.office.deepin) For Archlinux
- pkgver = 3.4.8.22092
+ pkgver = 3.4.8.22121
pkgrel = 1
url = https://tim.qq.com/
install = deepin-wine-tim.install
arch = x86_64
license = custom
+ depends = hicolor-icon-theme
+ depends = bash
+ depends = xdg-utils
depends = p7zip
depends = deepin-wine5
depends = deepin-wine-helper>=5.1.30_1-1
@@ -21,12 +24,12 @@ pkgbase = deepin-wine-tim
conflicts = deepin.com.qq.office
conflicts = deepin-tim-for-arch
source = https://com-store-packages.uniontech.com/appstore/pool/appstore/c/com.qq.im.deepin/com.qq.im.deepin_9.3.2deepin20_i386.deb
- source = https://dldir1.qq.com/qqfile/qq/TIM3.4.8/TIM3.4.8.22092.exe
+ source = https://dldir1.qq.com/qqfile/qq/TIM3.4.8/TIM3.4.8.22121.exe
source = run.sh
source = share.7z
md5sums = 5fdc20e614d945bd2ba5251420872479
- md5sums = 9d1eb0780c8ea41c3f3180cce6d5663f
- md5sums = edea06578ee76f9563f83d67d9e33cc6
+ md5sums = 9435b99a95cad04f242086928d8f390c
+ md5sums = d59796e26ddb01ab3f796fe246716c22
md5sums = 479ae2a04a9c5dcc08c67c7b1395a944
pkgname = deepin-wine-tim
diff --git a/PKGBUILD b/PKGBUILD
index f1d083fc9a37..dbae68abeae4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
-# Maintainer: asukaminato <asukaminato at nyan dot eu dot org>
+# Maintainer: asukaminato <i at asukaminato at eu dot org>
# Contributor: Codist <countstarlight@gmail.com>
# Contributor: Aron Young <tkf6fkt at gmail dot com>
pkgname=deepin-wine-tim
_pkgver=3.4.8
-pkgver="$_pkgver".22092
+pkgver="$_pkgver".22121
_debpkgver=9.3.2deepin20
_debpkgname="com.qq.im.deepin"
_timpkgname="com.qq.office.deepin"
@@ -13,7 +13,7 @@ pkgdesc="Tencent TIM on Deepin Wine5(${_timpkgname}) For Archlinux"
arch=("x86_64")
url="https://tim.qq.com/"
license=('custom')
-depends=('p7zip' 'deepin-wine5' 'deepin-wine-helper>=5.1.30_1-1' 'xorg-xwininfo' 'wqy-microhei' 'lib32-alsa-lib' 'lib32-alsa-plugins' 'lib32-libpulse' 'lib32-openal' 'lib32-mpg123' 'lib32-gnutls')
+depends=('hicolor-icon-theme' 'bash' 'xdg-utils' 'p7zip' 'deepin-wine5' 'deepin-wine-helper>=5.1.30_1-1' 'xorg-xwininfo' 'wqy-microhei' 'lib32-alsa-lib' 'lib32-alsa-plugins' 'lib32-libpulse' 'lib32-openal' 'lib32-mpg123' 'lib32-gnutls')
conflicts=('wine-tim' 'deepin.com.qq.office' 'deepin-tim-for-arch')
install="deepin-wine-tim.install"
_mirror="https://com-store-packages.uniontech.com"
@@ -22,8 +22,8 @@ source=("$_mirror/appstore/pool/appstore/c/${_debpkgname}/${_debpkgname}_${_debp
"run.sh"
"share.7z")
md5sums=('5fdc20e614d945bd2ba5251420872479'
- '9d1eb0780c8ea41c3f3180cce6d5663f'
- 'edea06578ee76f9563f83d67d9e33cc6'
+ '9435b99a95cad04f242086928d8f390c'
+ 'd59796e26ddb01ab3f796fe246716c22'
'479ae2a04a9c5dcc08c67c7b1395a944')
build() {
diff --git a/gen.sh b/gen.sh
deleted file mode 100755
index 63da9e0202bb..000000000000
--- a/gen.sh
+++ /dev/null
@@ -1,88 +0,0 @@
-#!/bin/sh
-
-PACKAGE_NAME="deepin-wine-tim"
-PACKAGE_SUFFIX=(".pkg.tar.xz" ".pkg.tar.zst")
-
-GenPatch()
-{
- diff -ruN reg_tmp/ reg_tmp_fixed/ > reg.patch
-}
-
-Extract()
-{
- rm -rf reg_tmp_fixed && \
- mkdir reg_tmp_fixed && \
- tar xvjf reg_files.tar.bz2 -C reg_tmp_fixed
-}
-
-GenSrcInfo()
-{
- makepkg --printsrcinfo > .SRCINFO
-}
-
-Clean()
-{
- git clean -xfd
-}
-
-Tar()
-{
- cd reg_tmp && \
- tar -cvjSf reg_files.tar.bz2 * && \
- mv reg_files.tar.bz2 ../ && \
- cd ../
-}
-
-Md5()
-{
- for i in "${PACKAGE_SUFFIX[@]}"; do
- find . -type f -name "${PACKAGE_NAME}*$i" -execdir sh -c 'md5sum "$1" > "$1.md5"' _ {} \;
- done
-}
-
-HelpApp()
-{
- echo " Extra Commands:"
- echo " -p/--patch Generate patch files between reg_tmp/ and reg_tmp_fixed/"
- echo " -e/--extract Extract reg files from reg_files.tar.bz2 to dir reg_tmp_fixed/"
- echo " -g/--gen Generate AUR package info to .SRCINFO"
- echo " -c/--clean Clean files which not track by git"
- echo " -t/--tar Package reg files"
- echo " -m/--md5 Generate the md5 file of each package"
- echo " -h/--help Show program help info"
-}
-
-if [ -z $1 ]; then
- # Default generate AUR package info
- GenSrcInfo
- exit 0
-fi
-case $1 in
- "-p" | "--patch")
- GenPatch
- ;;
- "-e" | "--extract")
- Extract
- ;;
- "-g" | "--gen")
- GenSrcInfo
- ;;
- "-c" | "--clean")
- Clean
- ;;
- "-t" | "--tar")
- Tar
- ;;
- "-m" | "--md5")
- Md5
- ;;
- "-h" | "--help")
- HelpApp
- ;;
- *)
- echo -e "\033[31mgen: unrecognized option '$1' \033[0m"
- echo "Use -h|--help to get help"
- exit 1
- ;;
-esac
-exit 0
diff --git a/run.sh b/run.sh
index 40a89de5c292..892ecf109542 100755
--- a/run.sh
+++ b/run.sh
@@ -13,7 +13,7 @@ BOTTLENAME="Deepin-TIM"
APPVER="9.3.2deepin20"
WINEPREFIX="$HOME/.deepinwine/$BOTTLENAME"
TIM_FONTS="$WINEPREFIX/drive_c/windows/Fonts"
-TIM_VER="3.4.8.22092"
+TIM_VER="3.4.8.22121"
EXEC_PATH="c:/Program Files/Tencent/TIM/Bin/TIM.exe"
EXEC_FILE="$WINEPREFIX/drive_c/Program Files/Tencent/TIM/Bin/TIM.exe"
START_SHELL_PATH="/opt/deepinwine/tools/run_v4.sh"