summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-09-22 15:22:19 -0500
committerLuis Martinez2022-09-22 15:22:19 -0500
commita7aeb4d87d29f2d4f33114e55339cebc637aa24e (patch)
tree4a11c88c4cb465e7ec71013a586faeb568557d14
parentf1d37de6ad5ffb2d88134e0a0847de78f7c8e67a (diff)
downloadaur-a7aeb4d87d29f2d4f33114e55339cebc637aa24e.tar.gz
update to 0.8.2
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md42
-rw-r--r--PKGBUILD4
3 files changed, 47 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d167ebf2ecfe..e0af0d76d401 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = apollo-rover
pkgdesc = CLI for Apollo's suite of GraphQL developer productivity tools
- pkgver = 0.8.1
+ pkgver = 0.8.2
pkgrel = 1
url = https://github.com/apollographql/rover
install = rover.install
@@ -12,7 +12,7 @@ pkgbase = apollo-rover
depends = zlib
replaces = apollo-rover-fed2
options = !lto
- source = apollo-rover-0.8.1.tar.gz::https://github.com/apollographql/rover/archive/v0.8.1.tar.gz
- sha256sums = 85ae6a9ca5c81f9b30cfbf56130dddad9b57e2fc895a0eccf27a88dd619ae905
+ source = apollo-rover-0.8.2.tar.gz::https://github.com/apollographql/rover/archive/v0.8.2.tar.gz
+ sha256sums = f6e6edf08fc95cf6ac56032b0752565d14c46a584f85b968c103ab1504567c78
pkgname = apollo-rover
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 4459ab4b68a3..2817aee69216 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -16,8 +16,50 @@ This project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.htm
## 🛠 Maintenance
+- **Link directly to API Keys page in Studio - @abernix, #1202**
+
+ The `rover config auth` command will now provide a link that takes you directly to the "API Keys" page where you can create a Personal API Key, rather than a page that requires you to click through to another page.
+
## 📚 Documentation -->
+# [0.8.2] - 2022-09-06
+
+## 🚀 Features
+
+- **Check commands exit with failure when downstream tasks fail - @sachindshinde, #1280**
+
+ Historically, `rover graph check` and `rover subgraph check` have aggregated errors for operation checks and/or composition checks. Checks are expanding in Studio and will continue to expand over time, starting with downstream contract checks for `rover subgraph check`. When these tasks fail, Rover will throw an error and link to the checks page in Studio which will contiain more information on the exact failure.
+
+- **Detect improper VS Code API key pastes on Windows - @EverlastingBugstopper, #1026, 1268**
+
+ We have added new error messages and recovery suggestions for malformed API keys caused by invalid copy+pastes in VS Code on Windows.
+
+- **Adds `--watch` to `introspect` commands - @EverlastingBugstopper, #1207**
+
+ If you pass the `--watch` flag to `rover graph introspect` or `rover subgraph introspect`, the GraphQL server will be introspected once every second, printing updates to the terminal as the introspection response changes. This could be used to bootstrap development workflows when combined with `--output json` and a tool like `jq`.
+
+## 🐛 Fixes
+
+- **Trim double quotes in multilingual descriptions - @lrlna, #1245 fixes #1244 and #1114**
+
+ `rover graph introspect` no longer crashes if a field description contains cyrillic symbols.
+
+- **Fix link to ELv2 license information - @EverlastingBugstopper, #1262 fixes #1261**
+
+## 🛠 Maintenance
+
+- **Link directly to API Keys page in Studio - @abernix, #1202**
+
+ The `rover config auth` command will now provide a link that takes you directly to the "API Keys" page where you can create a Personal API Key, rather than a page that requires you to click through to another page.
+
+- **Skip Apollo Studio integration tests for fork PRs - @EverlastingBugstopper, #Issue #, 1216**
+
+ Our CI pipeline skips Apollo Studio integration tests for forked repositories because they don't have access to the Apollo Studio organization that we use to run them.
+
+- **Updates MacOS CI pipeline to use xcode 13.4 - @EverlastingBugstopper, #1211**
+
+- **Normalize git remote URLs for anonymized telemetry - @EverlastingBugstopper, #1279**
+
# [0.8.1] - 2022-07-28
## 🐛 Fixes
diff --git a/PKGBUILD b/PKGBUILD
index e67432d8af7c..a0014d2ad5c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=apollo-rover
-pkgver=0.8.1
+pkgver=0.8.2
pkgrel=1
pkgdesc="CLI for Apollo's suite of GraphQL developer productivity tools"
arch=('x86_64')
@@ -14,7 +14,7 @@ options=('!lto')
install=rover.install
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('85ae6a9ca5c81f9b30cfbf56130dddad9b57e2fc895a0eccf27a88dd619ae905')
+sha256sums=('f6e6edf08fc95cf6ac56032b0752565d14c46a584f85b968c103ab1504567c78')
prepare() {
cd "rover-$pkgver"