summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYurii Kolesnykov2023-03-30 14:50:00 +0300
committerYurii Kolesnykov2023-03-30 14:50:00 +0300
commita7dcfc0f96b7479201dda4852ef8167eb79f0418 (patch)
treeee88edc9faa809fa5e28cbdb664733c22c20a793
parent6d3b3a91e91a7fa0a0e09cf36b4cd84536dfacf0 (diff)
downloadaur-a7dcfc0f96b7479201dda4852ef8167eb79f0418.tar.gz
fix build
Signed-off-by: Yurii Kolesnykov <root@yurikoles.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--config9
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c266aaf6e54..2601b74a15d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-amd-git
pkgdesc = Linux kernel with WIP AMDGPU material
- pkgver = 6.2.r1156607.7ee938ac0060
+ pkgver = 6.3.r1170246.402f3aff8c82
pkgrel = 1
url = https://gitlab.freedesktop.org/agd5f/linux
arch = x86_64
@@ -23,7 +23,7 @@ pkgbase = linux-amd-git
source = linux-amd-git::git+https://gitlab.freedesktop.org/agd5f/linux.git#branch=drm-next
source = config
sha256sums = SKIP
- sha256sums = f9a0027bea53a7160759858c535eb0ba0b3bea34c0130f47f2d5bba75d102170
+ sha256sums = aa354003751aeeadba82211ab9e4da0ef672cb6838a64cc5d5d1a47292583a69
pkgname = linux-amd-git
pkgdesc = The Linux kernel with WIP AMDGPU material kernel and modules
diff --git a/PKGBUILD b/PKGBUILD
index cbf74fd4c4e2..ee9f3541d3d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Based on testing/linux by Jan Alexander Steffens (heftig) <heftig@archlinux.org>
pkgbase=linux-amd-git
-pkgver=6.2.r1156607.7ee938ac0060
+pkgver=6.3.r1170246.402f3aff8c82
pkgrel=1
pkgdesc='Linux kernel with WIP AMDGPU material'
_product="${pkgbase%-git}"
@@ -22,10 +22,11 @@ source=(
config # the main kernel config file
)
sha256sums=('SKIP'
- 'f9a0027bea53a7160759858c535eb0ba0b3bea34c0130f47f2d5bba75d102170')
+ 'aa354003751aeeadba82211ab9e4da0ef672cb6838a64cc5d5d1a47292583a69')
pkgver() {
cd $_srcname
+
local version="$(grep \^VERSION Makefile|cut -d"=" -f2|cut -d" " -f2)"
local patch="$(grep \^PATCHLEVEL Makefile|cut -d"=" -f2|cut -d" " -f2)"
@@ -40,7 +41,7 @@ prepare() {
cd $_srcname
echo "Setting version..."
- KERNELVERSION="${pkgver}" scripts/setlocalversion
+ # scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
@@ -113,7 +114,7 @@ _package-headers() {
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
# required when DEBUG_INFO_BTF_MODULES is enabled
- install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
+ # install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
echo "Installing headers..."
cp -t "$builddir" -a include
diff --git a/config b/config
index 173ab7747f66..bd840edcf945 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 6.2.5-arch1 Kernel Configuration
+# Linux/x86 6.2.8-arch1 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 12.2.1 20230201"
CONFIG_CC_IS_GCC=y
@@ -4494,7 +4494,6 @@ CONFIG_SERIAL_ARC_NR_PORTS=1
CONFIG_SERIAL_RP2=m
CONFIG_SERIAL_RP2_NR_UARTS=32
CONFIG_SERIAL_FSL_LPUART=m
-CONFIG_SERIAL_FSL_LPUART_CONSOLE=y
CONFIG_SERIAL_FSL_LINFLEXUART=m
CONFIG_SERIAL_MEN_Z135=m
CONFIG_SERIAL_SPRD=m
@@ -10994,9 +10993,9 @@ CONFIG_DEBUG_INFO_DWARF5=y
CONFIG_DEBUG_INFO_COMPRESSED_NONE=y
# CONFIG_DEBUG_INFO_COMPRESSED_ZLIB is not set
# CONFIG_DEBUG_INFO_SPLIT is not set
-CONFIG_DEBUG_INFO_BTF=y
-CONFIG_PAHOLE_HAS_SPLIT_BTF=y
-CONFIG_DEBUG_INFO_BTF_MODULES=y
+# CONFIG_DEBUG_INFO_BTF is not set
+# CONFIG_PAHOLE_HAS_SPLIT_BTF is not set
+# CONFIG_DEBUG_INFO_BTF_MODULES is not set
# CONFIG_MODULE_ALLOW_BTF_MISMATCH is not set
# CONFIG_GDB_SCRIPTS is not set
CONFIG_FRAME_WARN=2048