summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJusitn Gallardo2018-07-29 19:01:55 -0700
committerJusitn Gallardo2018-07-29 19:01:55 -0700
commita7f2358be9f1f60b840488ad10a6d0e3beb4ebaa (patch)
tree8cf474417411980de4dfe34c5549453428097aab
downloadaur-a7f2358be9f1f60b840488ad10a6d0e3beb4ebaa.tar.gz
xjwt v1.0.3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aef166af5254
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = xjwt
+ pkgdesc = Minimal C library for validation of real-world JWTs
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/ScaleFT/libxjwt
+ arch = x86_64
+ license = Apache
+ depends = openssl
+ depends = jansson
+ source = https://github.com/ScaleFT/libxjwt/releases/download/v1.0.3/libxjwt-1.0.3.tar.gz
+ sha256sums = c23488b452be920efbbafe01439269b68edca1b750c63608b005c482beb75f40
+
+pkgname = xjwt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44e26a37e3c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Justin Gallardo <me@jirw.in>
+pkgname=xjwt
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Minimal C library for validation of real-world JWTs"
+arch=(x86_64)
+url="https://github.com/ScaleFT/libxjwt"
+license=('Apache')
+depends=(openssl jansson)
+source=("https://github.com/ScaleFT/libxjwt/releases/download/v1.0.3/libxjwt-$pkgver.tar.gz")
+sha256sums=(c23488b452be920efbbafe01439269b68edca1b750c63608b005c482beb75f40)
+
+prepare() {
+ cd "lib$pkgname-$pkgver"
+}
+
+build() {
+ cd "lib$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "lib$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}