summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Dünkelmann2021-06-27 15:28:31 +0200
committerMartin Dünkelmann2021-06-27 15:28:31 +0200
commita7f671d006f340f40ff3f40424f126c62bf977d1 (patch)
tree3f20d691522d71771d8759cdeb231dce41b222a6
downloadaur-a7f671d006f340f40ff3f40424f126c62bf977d1.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD54
-rw-r--r--README.txt98
3 files changed, 170 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0df0acc23237
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = kyocera-sane
+ pkgdesc = Kyocera sane scanner support package for many Kyocera printers.
+ pkgver = 2.0.0326
+ pkgrel = 1
+ url = https://www.kyocera.com/
+ arch = x86_64
+ license = custom
+ makedepends = unzip
+ makedepends = wget
+ depends = glibc
+ depends = libusb
+ depends = libtiff4
+ depends = openssl-1.0
+ depends = sane
+ source = https://www.kyoceradocumentsolutions.de/content/download-center/de/drivers/all/SANE_Driver_zip.download.zip
+ sha256sums = 4bf3f83b0cec6531e794151c076586fcc0f4262fdffa9f2a465ce684aff6f90a
+
+pkgname = kyocera-sane
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dea098d38969
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Martin Dünkelmann <nc-duenkekl3@netcologne.de>
+pkgname=kyocera-sane
+pkgver=2.0.0326
+pkgrel=1
+pkgdesc="Kyocera sane scanner support package for many Kyocera printers."
+arch=('x86_64')
+url="https://www.kyocera.com/"
+license=('custom')
+depends=('glibc' 'libusb' 'libtiff4' 'openssl-1.0' 'sane')
+makedepends=('unzip' 'wget')
+source=("https://www.kyoceradocumentsolutions.de/content/download-center/de/drivers/all/SANE_Driver_zip.download.zip")
+sha256sums=('4bf3f83b0cec6531e794151c076586fcc0f4262fdffa9f2a465ce684aff6f90a')
+
+prepare() {
+ cd ${srcdir}
+ unzip -o SANE_Driver_zip.download.zip
+ ar xv ${pkgname}_${pkgver}_amd64.deb
+}
+
+package() {
+ cd ${pkgdir}
+
+ tar xzf ${srcdir}/data.tar.gz -C .
+
+ # clean unnecessary files
+ rm usr/share/doc/${pkgname}/changelog.Debian.gz
+ rm usr/lib/sane/libsane-kyocera.so.1
+ rm usr/lib/sane/libsane-kyocera_gdi_a3.so.1
+ rm -rf usr/lib/x86_64-linux-gnu
+ rm -rf usr/local
+
+ # fix licence warning
+ mkdir -p usr/share/licenses/${pkgname}
+ mv usr/share/doc/${pkgname}/copyright usr/share/licenses/${pkgname}/COPYRIGHT
+
+ # from deb preinst
+ #chmod 1770 usr/local/kyocera
+ #chmod 1770 usr/local/kyocera/scanner
+
+ # from deb postinst
+ mkdir -p etc/sane.d/dll.d/
+ touch etc/sane.d/dll.d/kyocera.conf
+ echo 'kyocera' >> etc/sane.d/dll.d/kyocera.conf
+ echo 'kyocera_gdi_a3' >> etc/sane.d/dll.d/kyocera.conf
+ echo 'kyocera_wc3' >> etc/sane.d/dll.d/kyocera.conf
+ echo 'kyocera_wc3_usb' >> etc/sane.d/dll.d/kyocera.conf
+
+ #ln -s usr/local/kyocera/scanner/libssl.so.1.0.0 /usr/lib/libssl.so.1.0.0
+ #ln -s usr/local/kyocera/scanner/libcrypto.so.1.0.0 /usr/lib/libcrypto.so.1.0.0
+ #ln -s usr/local/kyocera/scanner/libjpeg.so.8.0.2 /usr/lib/libjpeg.so.8
+ #ln -sf usr/local/kyocera/scanner/libtiff.so.4.3.4 /usr/lib/libtiff.so.4
+
+ #ldconfig
+} \ No newline at end of file
diff --git a/README.txt b/README.txt
new file mode 100644
index 000000000000..fc5b2cbfb714
--- /dev/null
+++ b/README.txt
@@ -0,0 +1,98 @@
+======================================================
+KYOCERA SANE DRIVER
+v2.0.0326
+
+(c) 2020 KYOCERA Document Solutions Inc.
+======================================================
+
+---------------------------------------------------------
+Provided packages
+---------------------------------------------------------
+For Ubuntu and Debian OS
+ - kyocera-sane_2.0.0326_i386.deb
+ - kyocera-sane_2.0.0326_amd64.deb
+
+For Fedora
+ - kyocera-sane-2.0-0326.i586.rpm
+ - kyocera-sane-2.0-0326.x86_64.rpm
+
+---------------------------------------------------------
+HOW TO INSTALL/UNINSTALL
+---------------------------------------------------------
+For Debian package:
+ Install / Upgrade from existing installation:
+ $ sudo dpkg -i [package-filename]
+ Uninstall (keep configuration files):
+ $ sudo dpkg -r kyocera-sane
+ Uninstall (purge / delete configuration files):
+ $ sudo dpkg -P kyocera-sane
+ Search / check installation
+ $ sudo dpkg -l | grep 'kyocera-sane'
+
+
+For RPM package:
+ Install:
+ # sudo rpm -ihv [package-filename]
+ Upgrade from existing installation:
+ For older RPM package until version 1.2.2729, KyoceraSANE driver must be uninstalled when upgrading to a newer RPM package.
+ # sudo rpm -e kyocera-sane
+ # sudo rpm -ihv [new-package-filename]
+ RPM package version starting from KyoceraSANE_v1.2.2729a may upgrade automatically to a newer RPM package without uninstalling old RPM package.
+ # sudo rpm -Uhv [package-filename]
+ Uninstall:
+ # sudo rpm -e kyocera-sane
+ Search / check installation
+ # rpm -qa | grep kyocera-sane
+
+
+
+Configuration for Network devices:
+
+ 1. After installing the Debian package, open the following file in a text editor.
+ /etc/sane.d/kyocera_devices.conf
+
+ 2. Add the hostname/IP address and model of your device as "<Hostname> <ModelName>".
+ E.g.
+ PC12345 FS-1135MFP
+ 192.168.1.100 FS-1135MFP
+
+ You can add more than 1 device to the list (1 device per line).
+ Please refer to instructions provided in configuration file for more details.
+
+NOTE: - SU privileges may be required to modify the configuration file.
+ - For RPM based OS, might need to configure Firewall settings and change interface to Internal or Trusted Zone to automatically detect devices.
+
+---------------------------------------------------------
+Supported OS
+---------------------------------------------------------
+- Ubuntu 18.04 LTS x64
+- Ubuntu 18.04 LTS x32
+- Fedora 31 x64
+- Fedora 30 x86
+- Debian 9 x64
+- Debian 9 x86
+
+---------------------------------------------------------
+USB Scan
+---------------------------------------------------------
+1. A4 USB scan was tested on ECOSYS M2040dn and ECOSYS M2640dw
+
+Limitations:
+1. XSane crashes when scanning 998 pages. In this scenario scanning, there are only 871 pages scanned
+2. Failure to install sane driver using package manager
+3. Invalid argument error is encountered when successive scan is performed via terminal commands
+4. Remote function is stopped after DP jam error is cleared
+5. Out of memory error" is encountered when scanning pages in Full Color mode (CentOS)
+6. Scanning via terminal is suddenly killed after scanning more than 370 A6 sheets
+7. Error occurs when cancellation is done almost at the end of scanning of 4 pages or more
+8. XSane crashes after the maximum of 998 scanned pages has been reached by the device.(CentOS)
+9. Error message is displayed during scanning of 998 pages (Ubuntu, Fedora, Debian)
+
+----------------------------------------------------------
+Note
+----------------------------------------------------------
+The following copyright notices apply:
+
+Copyright (c) 1998-2011 The OpenSSL Project. All rights reserved.
+Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com)
+ All rights reserved. \ No newline at end of file