summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfenuks2018-04-29 17:35:17 +0200
committerfenuks2018-04-29 17:35:17 +0200
commita8041c5cdaf2ecda340ce22389116a9920cc4d3c (patch)
tree26f536b4ef4f843ebd02fccf0aaf0ea45c0206ed
parentf09e3c1968279977d7f8cb6461b9be52d436be72 (diff)
downloadaur-a8041c5cdaf2ecda340ce22389116a9920cc4d3c.tar.gz
Make most dependencies optional
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD15
2 files changed, 20 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f31012c9524a..512f7be03200 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Apr 25 22:38:37 UTC 2018
+# Sun Apr 29 15:34:34 UTC 2018
pkgbase = python-language-server
pkgdesc = An implementation of the Language Server Protocol for Python
pkgver = 0.18.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/palantir/python-language-server
arch = any
license = MIT
@@ -12,13 +12,14 @@ pkgbase = python-language-server
depends = python-json-rpc
depends = python-future
depends = python-jedi
- depends = python-mccabe
depends = python-pluggy
- depends = python-pycodestyle
- depends = python-pyflakes
- depends = python-rope
- depends = yapf
- depends = pydocstyle
+ optdepends = python-mccabe: for complexity checking
+ optdepends = python-rope: for completions and renaming
+ optdepends = python-pyflakes: for linter to detect various errors
+ optdepends = python-pycodestyle: for style checking
+ optdepends = autopep8: for code formatting
+ optdepends = yapf: for code formatting (preferred over autopep8)
+ optdepends = pydocstyle: for docstring style checking
conflicts = python-language-server
conflicts = python-language-server-git
source = https://github.com/palantir/python-language-server/archive/0.18.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index aa0136462d27..7c66fa59fbde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,21 @@
pkgname=python-language-server
pkgver=0.18.0
-pkgrel=1
+pkgrel=2
pkgdesc="An implementation of the Language Server Protocol for Python"
arch=("any")
url="https://github.com/palantir/${pkgname}"
license=("MIT")
-depends=("python" "python-json-rpc" "python-future" "python-jedi" "python-mccabe"
- "python-pluggy" "python-pycodestyle" "python-pyflakes" "python-rope" "yapf" "pydocstyle")
-# optdepends=("python-language-server-mypy: mypy type checking")
+depends=("python" "python-json-rpc" "python-future" "python-jedi" "python-pluggy")
+optdepends=(
+ "python-mccabe: for complexity checking"
+ "python-rope: for completions and renaming"
+ "python-pyflakes: for linter to detect various errors"
+ "python-pycodestyle: for style checking"
+ "autopep8: for code formatting"
+ "yapf: for code formatting (preferred over autopep8)"
+ "pydocstyle: for docstring style checking"
+)
makedepends=("python-setuptools")
conflicts=("${pkgname}" "${pkgname}-git")
# install=$pkgname.install