summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCassandra Watergate2022-04-26 12:54:23 -0700
committerCassandra Watergate2022-04-26 12:54:23 -0700
commita80b5fa2ccbaea84696f8d24fc63e89d655f6d5a (patch)
tree4b25ac2cb1492bfeff5bf2f04d1d15ef16a48451
parent4c7a85f72ba782d840891e4ea306f14f0d949e74 (diff)
downloadaur-a80b5fa2ccbaea84696f8d24fc63e89d655f6d5a.tar.gz
update, add patch
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
-rw-r--r--basename.patch13
3 files changed, 25 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4034396166a7..9aa372a82bb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tgs-to-gif-cpp-git
pkgdesc = Animated stickers for Telegram (*.tgs) to animated GIFs converter, c++ version
pkgver = 0.1.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ed-asriyan/tgs-to-gif
arch = x86_64
arch = i386
@@ -12,9 +12,10 @@ pkgbase = tgs-to-gif-cpp-git
license = MIT
makedepends = conan
makedepends = cmake
- depends = rlottie-tdesktop
+ depends = rlottie
source = git+https://github.com/ed-asriyan/tgs-to-gif
- md5sums = SKIP
+ source = basename.patch
+ sha256sums = SKIP
+ sha256sums = d5b6f6c734ed8dbc6ffed897e2789d3a6e2a93b5ff3cf85bf6d42298353d1e9f
pkgname = tgs-to-gif-cpp-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 4c7fe3954bf6..2e1171686ce6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
# Maintainer: saltedcoffii <55339220+saltedcoffii@users.noreply.github.com>
pkgname=tgs-to-gif-cpp-git
pkgver=0.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="Animated stickers for Telegram (*.tgs) to animated GIFs converter, c++ version"
arch=("x86_64" "i386" "arm" "armv6h" "armv7h" "aarch64")
url="https://github.com/ed-asriyan/tgs-to-gif"
license=('MIT')
-depends=('rlottie-tdesktop')
-# The package 'rlottie-git' also works but I don't know the syntax to allow the user choice. Please help patch this.
+depends=('rlottie')
makedepends=('conan' 'cmake')
-source=("git+https://github.com/ed-asriyan/tgs-to-gif")
-md5sums=("SKIP")
+source=("git+https://github.com/ed-asriyan/tgs-to-gif"
+ basename.patch)
+sha256sums=('SKIP'
+ 'd5b6f6c734ed8dbc6ffed897e2789d3a6e2a93b5ff3cf85bf6d42298353d1e9f')
build() {
cd "tgs-to-gif"
git checkout master-cpp
+ patch -Np1 -i ../basename.patch
conan install . --build
cmake CMakeLists.txt
make
diff --git a/basename.patch b/basename.patch
new file mode 100644
index 000000000000..59d94270a6c2
--- /dev/null
+++ b/basename.patch
@@ -0,0 +1,13 @@
+diff --git a/main.cpp b/main.cpp
+index beebb1d..13dca56 100644
+--- a/main.cpp
++++ b/main.cpp
+@@ -30,7 +30,7 @@ bool convert(std::string filePath, auto width, auto height, auto alphaThreshold,
+ }
+
+ int main(int argc, const char** argv) {
+- argparse::ArgumentParser program("tgs-to-gif");
++ argparse::ArgumentParser program(basename(argv[0]));
+
+ program.add_argument("path")
+ .required()