summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2020-05-12 13:55:45 +0300
committerAdrian Perez de Castro2020-05-12 13:55:45 +0300
commita80eff2f879f1f9d506b94ff4831078630510237 (patch)
treeb908058b9a5e78dcb2cb0ee74c26cb0462b4e68b
parent5194f2bb6a05fc78d6db4afe493d3a4085b8a8b6 (diff)
downloadaur-a80eff2f879f1f9d506b94ff4831078630510237.tar.gz
Bump to version 5.2.3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
-rw-r--r--remove-werror.patch10
-rw-r--r--system-blocksruntime.patch26
4 files changed, 39 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43b0ef137b62..c9a413def00d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libdispatch
pkgdesc = Comprehensive support for concurrent code execution on multicore hardware
- pkgver = 5.1.4
- pkgrel = 2
+ pkgver = 5.2.3
+ pkgrel = 1
url = https://apple.github.io/swift-corelibs-libdispatch
arch = i686
arch = x86_64
@@ -17,10 +17,12 @@ pkgbase = libdispatch
conflicts = libdispatch-git
conflicts = swift
conflicts = swift-development
- source = libdispatch::git+https://github.com/apple/swift-corelibs-libdispatch.git#tag=swift-5.1.4-RELEASE
+ source = libdispatch::git+https://github.com/apple/swift-corelibs-libdispatch.git#tag=swift-5.2.3-RELEASE
+ source = remove-werror.patch
source = system-blocksruntime.patch
sha512sums = SKIP
- sha512sums = 2a7950849d4244308674b997d07dd088c534acdc3d9229354257270177703fdaaaa39a65885c8550fd98d0d3fcaea569a539a46c4bc465f9a8c6ad26244170fc
+ sha512sums = d7d05ff6fa2ece40fea51e97f1af04e25ae9c2b55246fa2d753c446cff380262e611f9abb5112b7c7c94730362f0d06e0ccd867477c9470d1154e9c65e540529
+ sha512sums = 01e5a11696390678fa0f327f21112d9373e54f4b7bf28a8a60a3ede40d2561fe061eae746d5c997a380226149dc76008c3b1fec8a799af96f1152c4a97500803
pkgname = libdispatch
diff --git a/PKGBUILD b/PKGBUILD
index 4678d80e830d..1ba62d09f087 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgname=libdispatch
-pkgver=5.1.4
-pkgrel=2
+pkgver=5.2.3
+pkgrel=1
pkgdesc='Comprehensive support for concurrent code execution on multicore hardware'
arch=(i686 x86_64 arm armv6h armv7h aarch64)
url=https://apple.github.io/swift-corelibs-libdispatch
@@ -10,22 +10,24 @@ depends=(libblocksruntime)
makedepends=(git clang cmake)
conflicts=(libdispatch-git swift swift-development)
source=("${pkgname}::git+https://github.com/apple/swift-corelibs-libdispatch.git#tag=swift-${pkgver}-RELEASE"
+ remove-werror.patch
system-blocksruntime.patch)
-sha512sums=(SKIP
- '2a7950849d4244308674b997d07dd088c534acdc3d9229354257270177703fdaaaa39a65885c8550fd98d0d3fcaea569a539a46c4bc465f9a8c6ad26244170fc')
+sha512sums=('SKIP'
+ 'd7d05ff6fa2ece40fea51e97f1af04e25ae9c2b55246fa2d753c446cff380262e611f9abb5112b7c7c94730362f0d06e0ccd867477c9470d1154e9c65e540529'
+ '01e5a11696390678fa0f327f21112d9373e54f4b7bf28a8a60a3ede40d2561fe061eae746d5c997a380226149dc76008c3b1fec8a799af96f1152c4a97500803')
prepare () {
cd "${pkgname}"
- patch -p1 < "${srcdir}/system-blocksruntime.patch"
+ patch -p0 < "${srcdir}/remove-werror.patch"
+ patch -p0 < "${srcdir}/system-blocksruntime.patch"
}
build () {
- CC=clang CXX=clang++ cmake -H"${pkgname}" -Bbuild \
+ CC=clang CXX=clang++ cmake -S"${pkgname}" -Bbuild \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBlocksRuntime_INCLUDE_DIR=/usr/include \
- -DBlocksRuntime_LIBRARIES=/usr/lib/libBlocksRuntime.so \
- "../${pkgname}"
+ -DBlocksRuntime_LIBRARIES=/usr/lib/libBlocksRuntime.so
cmake --build build -j $(nproc)
}
diff --git a/remove-werror.patch b/remove-werror.patch
new file mode 100644
index 000000000000..e50ba5ed9614
--- /dev/null
+++ b/remove-werror.patch
@@ -0,0 +1,10 @@
+--- cmake/modules/DispatchCompilerWarnings.cmake.orig 2020-05-12 13:13:59.619689872 +0300
++++ cmake/modules/DispatchCompilerWarnings.cmake 2020-05-12 13:13:35.216171428 +0300
+@@ -2,7 +2,6 @@
+ if("${CMAKE_C_SIMULATE_ID}" STREQUAL "MSVC")
+ # TODO: someone needs to provide the msvc equivalent warning flags
+ else()
+- add_compile_options($<$<OR:$<COMPILE_LANGUAGE:C>,$<COMPILE_LANGUAGE:CXX>>:-Werror>)
+ add_compile_options($<$<OR:$<COMPILE_LANGUAGE:C>,$<COMPILE_LANGUAGE:CXX>>:-Wall>)
+ add_compile_options($<$<OR:$<COMPILE_LANGUAGE:C>,$<COMPILE_LANGUAGE:CXX>>:-Wextra>)
+
diff --git a/system-blocksruntime.patch b/system-blocksruntime.patch
index fa7762afcc54..d92fcf9ccdee 100644
--- a/system-blocksruntime.patch
+++ b/system-blocksruntime.patch
@@ -1,17 +1,17 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 9f3f221..dd6c7a3 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -123,7 +123,7 @@ endif()
-
- option(INSTALL_PRIVATE_HEADERS "installs private headers in the same location as the public ones" OFF)
-
+--- src/CMakeLists.txt.orig 2020-05-12 13:16:34.317545662 +0300
++++ src/CMakeLists.txt 2020-05-12 13:16:41.670936116 +0300
+@@ -1,8 +1,3 @@
+-
-if(NOT CMAKE_SYSTEM_NAME STREQUAL Darwin)
-+if(NOT CMAKE_SYSTEM_NAME STREQUAL Darwin AND OFF)
- set(BlocksRuntime_INCLUDE_DIR ${PROJECT_SOURCE_DIR}/src/BlocksRuntime)
-
- # NOTE(compnerd) use the `BUILD_SHARED_LIBS` variable to determine what type
-@@ -182,6 +182,7 @@ if(__BUILTIN_TRAP)
+- add_subdirectory(BlocksRuntime)
+-endif()
+-
+ add_library(dispatch
+ allocator.c
+ apply.c
+--- CMakeLists.txt.orig 2020-05-12 13:24:24.764607466 +0300
++++ CMakeLists.txt 2020-05-12 13:24:27.634630553 +0300
+@@ -114,6 +114,7 @@
endif()
find_package(LibRT)