summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2015-07-05 18:13:39 -0600
committernot_anonymous2015-07-05 18:13:39 -0600
commita81bfd4cfa92a6ff39e0a63b0aaf65ea9353b45c (patch)
tree880e727bd35611a2f554fff6440bc28dd95b27b4
downloadaur-a81bfd4cfa92a6ff39e0a63b0aaf65ea9353b45c.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
-rw-r--r--qgrid.desktop14
-rw-r--r--qgrid.install11
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9fe75f5483c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = qgrid
+ pkgdesc = Ham Radio - Maidenhead grid squares calculator
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = http://users.telenet.be/on4qz/qgrid/index.html
+ install = qgrid.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = imagemagick
+ depends = qt4
+ source = http://users.telenet.be/on4qz/qgrid/downloads/qgrid_3.0.0.tgz
+ source = qgrid.desktop
+ md5sums = eaf8e11aa5bfdd11db6bf2928e0ae471
+ md5sums = b26691ae306781aec38688a95e581006
+ sha256sums = 143599f23ce45c443c0ca76c1af64a38cf190f1dfd061ac21a941ac6c8990fea
+ sha256sums = 7a63662e7dce377a86a4e66f6a2f86cebae7dc17146dacbe76eae7c340ad4737
+
+pkgname = qgrid
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f22dafd98399
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+
+pkgname=qgrid
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Ham Radio - Maidenhead grid squares calculator"
+arch=('i686' 'x86_64')
+url="http://users.telenet.be/on4qz/qgrid/index.html"
+license=('GPL3')
+depends=('qt4')
+makedepends=('imagemagick')
+install=$pkgname.install
+source=(http://users.telenet.be/on4qz/$pkgname/downloads/${pkgname}_$pkgver.tgz
+ $pkgname.desktop)
+
+prepare() {
+ cd $srcdir/${pkgname}_$pkgver
+
+ qmake-qt4
+ sed -i -e "s:local/::g" Makefile
+
+ convert icons/$pkgname.xpm $pkgname.png
+}
+
+build() {
+ cd $srcdir/${pkgname}_$pkgver
+
+ make
+}
+
+package() {
+ cd $srcdir/${pkgname}_$pkgver
+
+ make INSTALL_ROOT=$pkgdir install_target
+
+ install -Dm644 ../*.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -Dm644 *.png $pkgdir/usr/share/pixmaps/$pkgname.png
+}
+md5sums=('eaf8e11aa5bfdd11db6bf2928e0ae471'
+ 'b26691ae306781aec38688a95e581006')
+sha256sums=('143599f23ce45c443c0ca76c1af64a38cf190f1dfd061ac21a941ac6c8990fea'
+ '7a63662e7dce377a86a4e66f6a2f86cebae7dc17146dacbe76eae7c340ad4737')
diff --git a/qgrid.desktop b/qgrid.desktop
new file mode 100644
index 000000000000..abd5b7d0aab9
--- /dev/null
+++ b/qgrid.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Name=QGrid
+Name[en_US]=QGrid
+Comment=Maidenhead grid squares calculator
+Comment[en_US]=Maidenhead grid squares calculator
+Exec=qgrid
+Icon=qgrid
+MimeType=text/plain;
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Application;HamRadio;
+X-DCOP-ServiceType=none
+X-KDE-SubstituteUID=false
diff --git a/qgrid.install b/qgrid.install
new file mode 100644
index 000000000000..2eaa60550d51
--- /dev/null
+++ b/qgrid.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}