summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2022-03-04 07:32:22 +0100
committerMichel Zou2022-03-04 07:32:22 +0100
commita81da9b2686a9b7eeb7feb142b0736b163aad1d2 (patch)
tree489835bc6c93e88a3fe33c040e408c323f8f2aba
parent5b3785da9abb51cef42d7cbaa25c58631223596d (diff)
downloadaur-a81da9b2686a9b7eeb7feb142b0736b163aad1d2.tar.gz
2.3.2
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD8
-rw-r--r--libidn2-mingw.patch95
3 files changed, 6 insertions, 108 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c93948ead35d..d2f4f75942c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Mon Jun 11 18:09:54 UTC 2018
pkgbase = mingw-w64-libidn2
pkgdesc = A free software implementation of IDNA2008 (mingw-w64)
- pkgver = 2.0.5
+ pkgver = 2.3.2
pkgrel = 1
url = http://www.gnu.org/software/libidn
arch = any
@@ -13,10 +11,7 @@ pkgbase = mingw-w64-libidn2
options = staticlibs
options = !strip
options = !buildflags
- source = https://ftp.gnu.org/pub/gnu/libidn/libidn2-2.0.5.tar.gz
- source = libidn2-mingw.patch
- sha256sums = 53f69170886f1fa6fa5b332439c7a77a7d22626a82ef17e2c1224858bb4ca2b8
- sha256sums = ec8c6f59b08b619396e3f34e4b023f19f693f7f230f0885ad833d88f43966413
+ source = https://ftp.gnu.org/pub/gnu/libidn/libidn2-2.3.2.tar.gz
+ sha256sums = 76940cd4e778e8093579a9d195b25fff5e936e9dc6242068528b437a76764f91
pkgname = mingw-w64-libidn2
-
diff --git a/PKGBUILD b/PKGBUILD
index 56f45750f795..32bb74d782ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mingw-w64-libidn2
-pkgver=2.0.5
+pkgver=2.3.2
pkgrel=1
pkgdesc="A free software implementation of IDNA2008 (mingw-w64)"
arch=(any)
@@ -8,10 +8,8 @@ license=("GPL3, LGPL3")
makedepends=(mingw-w64-configure)
depends=(mingw-w64-crt mingw-w64-libunistring)
options=(staticlibs !strip !buildflags)
-source=("https://ftp.gnu.org/pub/gnu/libidn/libidn2-${pkgver}.tar.gz"
- libidn2-mingw.patch)
-sha256sums=('53f69170886f1fa6fa5b332439c7a77a7d22626a82ef17e2c1224858bb4ca2b8'
- 'ec8c6f59b08b619396e3f34e4b023f19f693f7f230f0885ad833d88f43966413')
+source=("https://ftp.gnu.org/pub/gnu/libidn/libidn2-${pkgver}.tar.gz")
+sha256sums=('76940cd4e778e8093579a9d195b25fff5e936e9dc6242068528b437a76764f91')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
diff --git a/libidn2-mingw.patch b/libidn2-mingw.patch
deleted file mode 100644
index 173100af1fc1..000000000000
--- a/libidn2-mingw.patch
+++ /dev/null
@@ -1,95 +0,0 @@
-diff -ur libidn2-0.16.orig/src/idn2.c libidn2-0.16/src/idn2.c
---- libidn2-0.16.orig/src/idn2.c 2017-02-06 18:33:44.840135786 +0100
-+++ libidn2-0.16/src/idn2.c 2017-02-06 18:59:32.753490461 +0100
-@@ -42,6 +42,68 @@
-
- #include "blurbs.h"
-
-+
-+size_t getline(char **lineptr, size_t *n, FILE *stream) {
-+ char *bufptr = NULL;
-+ char *p = bufptr;
-+ size_t size;
-+ int c;
-+
-+ if (lineptr == NULL) {
-+ return -1;
-+ }
-+ if (stream == NULL) {
-+ return -1;
-+ }
-+ if (n == NULL) {
-+ return -1;
-+ }
-+ bufptr = *lineptr;
-+ size = *n;
-+
-+ c = fgetc(stream);
-+ if (c == EOF) {
-+ return -1;
-+ }
-+ if (bufptr == NULL) {
-+ bufptr = malloc(128);
-+ if (bufptr == NULL) {
-+ return -1;
-+ }
-+ size = 128;
-+ }
-+ p = bufptr;
-+ while(c != EOF) {
-+ if ((p - bufptr) > (size - 1)) {
-+ size = size + 128;
-+ bufptr = realloc(bufptr, size);
-+ if (bufptr == NULL) {
-+ return -1;
-+ }
-+ }
-+ *p++ = c;
-+ if (c == '\n') {
-+ break;
-+ }
-+ c = fgetc(stream);
-+ }
-+
-+ *p++ = '\0';
-+ *lineptr = bufptr;
-+ *n = size;
-+
-+ return p - bufptr - 1;
-+}
-+
-+
-+
-+
-+
-+
-+
-+
-+
-+
- const char version_etc_copyright[] =
- /* Do *not* mark this string for translation. %s is a copyright
- symbol suitable for this locale, and %d is the copyright
-@@ -161,9 +223,10 @@
- free (output);
- }
- else
-- error (EXIT_FAILURE, 0, "%s: %s",
-+ exit(EXIT_FAILURE);
-+ /*error (EXIT_FAILURE, 0, "%s: %s",
- args_info.register_given ? "register" : "lookup",
-- idn2_strerror (rc));
-+ idn2_strerror (rc));*/
- }
-
- int
-@@ -222,7 +285,8 @@
- }
-
- if (ferror (stdin))
-- error (EXIT_FAILURE, errno, "%s", _("input error"));
-+ exit(EXIT_FAILURE);
-+ /*error (EXIT_FAILURE, errno, "%s", _("input error"));*/
-
- cmdline_parser_free (&args_info);
-