summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzargbell2018-07-30 13:17:04 +0300
committerzargbell2018-07-30 13:17:04 +0300
commita824736d3db50bf7ac2bdd28a629bc47d4294887 (patch)
tree8e69362d9056e34dc7c34094024ae888b18044e7
downloadaur-a824736d3db50bf7ac2bdd28a629bc47d4294887.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD41
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..18a121fceb88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pixiecore-git
+ pkgdesc = An all-in-one tool for easy netbooting
+ pkgver = r306.870d490
+ pkgrel = 1
+ url = https://github.com/google/netboot
+ arch = x86_64
+ arch = armv7h
+ license = GPL2
+ makedepends = git
+ makedepends = go
+ depends = glibc
+ provides = pixiecore
+ conflicts = pixiecore
+
+pkgname = pixiecore-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..101dcca03c84
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: zargbell <zargbell@yandex.ru>
+pkgname=pixiecore-git
+pkgver=r306.870d490
+pkgrel=1
+pkgdesc="An all-in-one tool for easy netbooting"
+arch=("x86_64" "armv7h")
+url="https://github.com/google/netboot"
+license=("GPL2")
+depends=("glibc")
+makedepends=("git" "go")
+optdepends=()
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+options=()
+
+
+prepare() {
+ export GOPATH="$srcdir/go"
+ mkdir -p $GOPATH
+
+ export GOBIN="$GOPATH/bin"
+ mkdir -p $GOBIN
+
+ go env
+
+ go get -d -v go.universe.tf/netboot/cmd/pixiecore
+}
+
+pkgver(){
+ cd "${GOPATH}/src/go.universe.tf/netboot/"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ go install -v go.universe.tf/netboot/cmd/pixiecore
+}
+
+package() {
+ install -Dm755 "$GOBIN/${pkgname%-git}" "${pkgdir}/usr/bin/${pkgname%-git}"
+} \ No newline at end of file