summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAtifChy2021-08-30 23:49:55 +0600
committerAtifChy2021-08-30 23:49:55 +0600
commita827e297a5d79a2e1869686c9b425f806c49b861 (patch)
treeb0152e2d72936b186f2783de94576d32c24bda40
downloadaur-a827e297a5d79a2e1869686c9b425f806c49b861.tar.gz
initial release of eww wayland PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD58
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f011351662d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = eww-wayland-git
+ pkgdesc = ElKowar's wacky widgets (Wayland Only)
+ pkgver = 70285e0_2021.08.27
+ pkgrel = 1
+ url = https://github.com/elkowar/eww
+ arch = any
+ license = MIT
+ makedepends = rustup
+ makedepends = git
+ depends = gtk3
+ provides = eww
+ conflicts = eww
+ source = git+https://github.com/elkowar/eww
+ md5sums = SKIP
+
+pkgname = eww-wayland-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da0cacd979e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Atif Chowdhury <iftakhar.awal@gmail.com>
+pkgname=eww-wayland-git
+_pkgname=eww
+pkgver=70285e0_2021.08.27
+pkgrel=1
+epoch=
+pkgdesc="ElKowar's wacky widgets (Wayland Only)"
+arch=('any')
+url="https://github.com/elkowar/eww"
+license=('MIT')
+groups=()
+depends=("gtk3")
+makedepends=("rustup" "git")
+checkdepends=()
+optdepends=()
+provides=("eww")
+conflicts=("eww")
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/elkowar/eww")
+noextract=()
+md5sums=("SKIP")
+validpgpkeys=()
+
+pkgver() {
+ cd ${_pkgname}
+ _commit=$(git rev-parse HEAD | cut -c1-7)
+ _date=$(git log -1 --date=short --pretty=format:%cd)
+ printf "%s_%s\n" "${_commit}" "${_date}" | sed 's/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ rustup toolchain install nightly
+ cargo +nightly build --release --no-default-features --features=wayland
+}
+
+package() {
+ cd "$_pkgname"
+
+ install -Dm755 target/release/eww "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/etc/xdg/${_pkgname}"
+ cp -r examples/eww-bar "${pkgdir}/etc/xdg/${_pkgname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+
+ echo "\
+_____________________________________________________________________
+| |
+| The example config can be found in /etc/xdg/eww |
+| |
+| For better experience, please write your own config. |
+| WIKI: https://elkowar.github.io/eww/configuration.html |
+| |
+|___________________________________________________________________|"
+}