summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYurii Kolesnykov2017-09-25 21:27:41 +0300
committerYurii Kolesnykov2017-09-25 21:27:41 +0300
commita8612c1f153217304d20d5023815f44ba5df7899 (patch)
tree606d8c5854b470cdda0a663fa84b9e1319f567f2
parent3dad1738270f56f67f79da4426cfee8fd238a1b8 (diff)
downloadaur-a8612c1f153217304d20d5023815f44ba5df7899.tar.gz
update
-rw-r--r--PKGBUILD15
-rw-r--r--linux.install18
2 files changed, 20 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2ebd2e52c686..f3919b12e339 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
-pkgbase=linux-amd-staging-drm-next-git
+pkgbase=linux-amd-staging-git-drm-next
pkgdesc='Linux kernel with AMDGPU DC patches'
_srcname=$pkgbase
+_kernel_rel=4.13
_branch=amd-staging-drm-next
_kernelname=${pkgbase#linux}
-_kernel_rel=4.13
-pkgver=4.13.692986.58e5ccdc343d
+pkgver=4.13.695032.dcae401d1113
pkgrel=1
arch=('x86_64')
url='https://cgit.freedesktop.org/~agd5f/linux/'
@@ -86,15 +86,12 @@ _package() {
cp arch/$KARCH/boot/bzImage "${pkgdir}/boot/vmlinuz-${pkgbase}"
# set correct depmod command for install
- cp -f "${startdir}/${install}" "${startdir}/${install}.pkg"
+ sed -e "s|%PKGBASE%|${pkgbase}|g;s|%KERNVER%|${_kernver}|g" \
+ "${startdir}/${install}" > "${startdir}/${install}.pkg"
true && install=${install}.pkg
- sed \
- -e "s/KERNEL_NAME=.*/KERNEL_NAME=${_kernelname}/" \
- -e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/" \
- -i "${startdir}/${install}"
# install mkinitcpio preset file for kernel
- install -D -m644 "${srcdir}/${pkgbase}.preset" "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
+ install -D -m644 "${srcdir}/linux.preset" "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
sed \
-e "1s|'linux.*'|'${pkgbase}'|" \
-e "s|ALL_kver=.*|ALL_kver=\"/boot/vmlinuz-${pkgbase}\"|" \
diff --git a/linux.install b/linux.install
index 046277584140..ef42413835ac 100644
--- a/linux.install
+++ b/linux.install
@@ -1,7 +1,15 @@
+# arg 1: the new package version
+# arg 2: the old package version
+
+KERNEL_NAME=
+KERNEL_VERSION=
+
post_install () {
# updating module dependencies
echo ">>> Updating module dependencies. Please wait ..."
- depmod %KERNVER%
+ depmod ${KERNEL_VERSION}
+ echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
+ mkinitcpio -p linux${KERNEL_NAME}
}
post_upgrade() {
@@ -11,7 +19,9 @@ post_upgrade() {
# updating module dependencies
echo ">>> Updating module dependencies. Please wait ..."
- depmod %KERNVER%
+ depmod ${KERNEL_VERSION}
+ echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
+ mkinitcpio -p linux${KERNEL_NAME}
if [ $(vercmp $2 3.13) -lt 0 ]; then
echo ">>> WARNING: AT keyboard support is no longer built into the kernel."
@@ -22,6 +32,6 @@ post_upgrade() {
post_remove() {
# also remove the compat symlinks
- rm -f boot/initramfs-%PKGBASE%.img
- rm -f boot/initramfs-%PKGBASE%-fallback.img
+ rm -f boot/initramfs-linux${KERNEL_NAME}.img
+ rm -f boot/initramfs-linux${KERNEL_NAME}-fallback.img
}