summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Mesa2016-05-13 17:35:11 -0500
committerSamuel Mesa2016-05-13 17:35:11 -0500
commita888912aed07c83732da2cef1cf83fd7dd0ae7dd (patch)
treee93fa5587ea93ac87165f1c26045a04f48acf254
downloadaur-a888912aed07c83732da2cef1cf83fd7dd0ae7dd.tar.gz
Initial package
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1e7babd7f8b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Fri May 13 22:31:29 UTC 2016
+pkgbase = sfcgal-git
+ pkgdesc = Wrapper around the CGAL library that intents to implement 2D and 3D operations on OGC standards models
+ pkgver = 806.bd9f8cb
+ pkgrel = 1
+ url = http://oslandia.github.io/SFCGAL/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = cgal>=4.1
+ depends = boost
+ depends = gmp
+ depends = mpfr
+ depends = openscenegraph
+ provides = sfcgal
+ conflicts = sfcgal
+ source = sfcgal::git://github.com/Oslandia/sfcgal.git
+ md5sums = SKIP
+
+pkgname = sfcgal-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8ed27ded403
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Samuel Fernando Mesa Giraldo < samuelmesa [at] linuxmail [dot] org >
+# Initial Maintainer: Hannes Graeuler < hgraeule [at] uos [dot] de >
+
+pkgname=sfcgal-git
+_pkgname=sfcgal
+pkgver=806.bd9f8cb
+pkgrel=1
+pkgdesc="Wrapper around the CGAL library that intents to implement 2D and 3D operations on OGC standards models"
+arch=(i686 x86_64)
+url="http://oslandia.github.io/SFCGAL/index.html"
+license=('GPL')
+groups=()
+depends=('cgal>=4.1' 'boost' 'gmp' 'mpfr' 'openscenegraph')
+makedepends=('cmake')
+provides=('sfcgal')
+conflicts=('sfcgal')
+source=('sfcgal'::'git://github.com/Oslandia/sfcgal.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ cmake -Wno-dev \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DSFCGAL_BUILD_VIEWER=1 \
+ -DSFCGAL_BUILD_EXAMPLES=1 \
+ -DSFCGAL_BUILD_TEST=1 .
+ make -j2
+}
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR=$pkgdir install
+ rm -rf $pkgdir/usr/include/CGAL
+}