summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpeeweep2019-11-02 10:36:22 +0800
committerpeeweep2019-11-02 10:39:34 +0800
commita88d84da7132707bd22f4efe3ca562467061e9df (patch)
tree2d12b588de0895d8f4c5d59f3f0c71414625e4de
parentf690985ee46e579fcbefa71c46b43613ceedf31c (diff)
downloadaur-a88d84da7132707bd22f4efe3ca562467061e9df.tar.gz
bumper version 2.0.0-5
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD10
-rw-r--r--muduo-2.0.0.tar.gzbin213064 -> 0 bytes
4 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08e045fe2952..afcc1a7eb308 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = muduo
pkgdesc = A C++ non-blocking multi-threaded network library
pkgver = 2.0.0
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/chenshuo/muduo
arch = i686
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = muduo
depends = protobuf
options = staticlibs
source = muduo-2.0.0.tar.gz::https://github.com/chenshuo/muduo/archive/v2.0.0.tar.gz
- sha256sums = eab872539e50ee3d0377f2b5421c512022eb3013
+ sha256sums = bf7ae8bd9fd54567c93e12ddbfbc25a69fe6a50e625f02743e7268df3760dc13
pkgname = muduo
diff --git a/.gitignore b/.gitignore
index 7a210d1ef85b..6cab266302e5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
*.pkg.tar.xz
-*.zip
+*.tar.gz
*.log
pkg/
src/
diff --git a/PKGBUILD b/PKGBUILD
index 41e58249cc73..08e3786b4564 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=muduo
pkgver=2.0.0
-pkgrel=4
+pkgrel=5
pkgdesc='A C++ non-blocking multi-threaded network library'
url='https://github.com/chenshuo/muduo'
license=(BSD)
@@ -11,11 +11,11 @@ arch=(i686 x86_64)
depends=(protobuf)
makedepends=(cmake boost)
options=(staticlibs)
-source=(${pkgname}-$pkgver.tar.gz::${url}/archive/v$pkgver.tar.gz)
-sha256sums=('eab872539e50ee3d0377f2b5421c512022eb3013')
+source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+sha256sums=('bf7ae8bd9fd54567c93e12ddbfbc25a69fe6a50e625f02743e7268df3760dc13')
build() {
- cd "${srcdir}/${pkgname}-$pkgver"
+ cd "${srcdir}/${pkgname}-${pkgver}"
sed -i '/-Werror/d' CMakeLists.txt
sed -i 's/option(MUDUO_BUILD_EXAMPLES "Build Muduo examples" ON/option(MUDUO_BUILD_EXAMPLES "Build Muduo examples" OFF/' CMakeLists.txt
INSTALL_DIR=/usr ./build.sh
@@ -24,5 +24,5 @@ build() {
package() {
cd "${srcdir}/build/release-cpp11"
make install DESTDIR="${pkgdir}"
- install -Dm644 "${srcdir}/${pkgname}-$pkgver/License" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/License" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/muduo-2.0.0.tar.gz b/muduo-2.0.0.tar.gz
deleted file mode 100644
index 3ef02c280623..000000000000
--- a/muduo-2.0.0.tar.gz
+++ /dev/null
Binary files differ