summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-04-12 21:42:35 +0200
committerhaawda2017-04-12 21:42:35 +0200
commita897d13ed971968974567ca9ef452ce8810373bb (patch)
tree52e0ddc493a5bbf3dd23c6ba10040358879637bf
parentb188da3076d46cb27deb773248a4ee0728e47722 (diff)
downloadaur-a897d13ed971968974567ca9ef452ce8810373bb.tar.gz
update with new patch
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD16
-rw-r--r--no_leafpad.patch36
3 files changed, 56 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 392537d7f7b9..7edd61bab597 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,27 @@
+# Generated by mksrcinfo v8
+# Wed Apr 12 19:42:25 UTC 2017
pkgbase = fotoxx
pkgdesc = A program for improving image files made with a digital camera
- pkgver = 17.04
+ pkgver = 17.04.1
pkgrel = 1
url = http://www.kornelix.net/fotoxx/fotoxx.html
arch = i686
arch = x86_64
license = GPL3
- makedepends = xdg-utils
depends = libraw
depends = gtk3
depends = libchamplain
depends = perl-image-exiftool>=0.8.6
+ depends = xdg-utils
optdepends = mashup: for composing pages to print from within fotoxx
- optdepends = brasero: for burning
+ optdepends = rawtherapee: for raw image processing
+ optdepends = dvd+rw-tools: for burning CDs,DVDs or BlueRays
+ optdepends = hugin: for panorama photos
options = !makeflags
- source = http://www.kornelix.net/downloads/tarballs/fotoxx-17.04.tar.gz
- md5sums = 93778e78ac90cab962a2fbca2c13c81b
+ source = http://www.kornelix.net/downloads/tarballs/fotoxx-17.04.1.tar.gz
+ source = no_leafpad.patch
+ sha512sums = 35953990681dd9e0c03848040059b174673ed3deffd8c62af88f40f7589c0b4955e5603736111dcd86f1d39cff45c31a5763eba8628ef5164f1b6234b1aef141
+ sha512sums = 803282be84e5065addb10841ed22c81821897f65b4efecf460d150c322e89384a2b13346cae832b5923d6634436e4b672ba72b3c1d56dd5cd2f2f4749c724b82
pkgname = fotoxx
diff --git a/PKGBUILD b/PKGBUILD
index 49ee4200040d..b86f552ab258 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=fotoxx
-pkgver=17.04
+pkgver=17.04.1
pkgrel=1
pkgdesc="A program for improving image files made with a digital camera"
url="http://www.kornelix.net/fotoxx/fotoxx.html"
arch=('i686' 'x86_64')
license=('GPL3')
-depends=('libraw' 'gtk3' 'libchamplain' 'perl-image-exiftool>=0.8.6')
-makedepends=('xdg-utils')
+depends=('libraw' 'gtk3' 'libchamplain' 'perl-image-exiftool>=0.8.6' 'xdg-utils')
optdepends=('mashup: for composing pages to print from within fotoxx'
- 'brasero: for burning')
-source=("http://www.kornelix.net/downloads/tarballs/$pkgname-$pkgver.tar.gz")
-md5sums=('93778e78ac90cab962a2fbca2c13c81b')
+ 'rawtherapee: for raw image processing'
+ 'dvd+rw-tools: for burning CDs,DVDs or BlueRays'
+ 'hugin: for panorama photos')
+source=("http://www.kornelix.net/downloads/tarballs/$pkgname-$pkgver.tar.gz" 'no_leafpad.patch')
+sha512sums=('35953990681dd9e0c03848040059b174673ed3deffd8c62af88f40f7589c0b4955e5603736111dcd86f1d39cff45c31a5763eba8628ef5164f1b6234b1aef141'
+ '803282be84e5065addb10841ed22c81821897f65b4efecf460d150c322e89384a2b13346cae832b5923d6634436e4b672ba72b3c1d56dd5cd2f2f4749c724b82')
options=('!makeflags')
prepare() {
cd $pkgname-$pkgver
- sed -i 's+xdg-deskto+#xdg-deskto+' Makefile
+ patch -Np1 < "$srcdir"/no_leafpad.patch || true
}
build() {
diff --git a/no_leafpad.patch b/no_leafpad.patch
new file mode 100644
index 000000000000..aedf8ae3e528
--- /dev/null
+++ b/no_leafpad.patch
@@ -0,0 +1,36 @@
+diff -Naur fotoxx-17.04.1.orig/fotoxx-17.04.1.cc fotoxx-17.04.1.new/fotoxx-17.04.1.cc
+--- fotoxx-17.04.1.orig/fotoxx-17.04.1.cc 2017-04-12 21:04:08.630207362 +0200
++++ fotoxx-17.04.1.new/fotoxx-17.04.1.cc 2017-04-12 21:08:28.118440955 +0200
+@@ -375,7 +375,7 @@
+
+ int initzfunc(void *)
+ {
+- int Fleafpad = 0, Fexiftool = 0, Fxdgopen = 0;
++ int Ftexteditor = 0, Fexiftool = 0, Fxdgopen = 0;
+ int ii, err, npid, contx;
+ FTYPE ftype;
+ char *pp, *pp2;
+@@ -405,8 +405,8 @@
+ if (exifver >= 8.60) Fexiftool = 1;
+ }
+
+- err = shell_quiet("which leafpad 1>2 2>/dev/null"); // check for leafpad 17.04
+- if (! err) Fleafpad = 1;
++ err = shell_quiet("which $EDITOR 1>2 2>/dev/null"); // check for texteditor 17.04
++ if (! err) Ftexteditor = 1;
+ err = shell_quiet("which xdg-open 1>2 2>/dev/null"); // check for xdg-open
+ if (! err) Fxdgopen = 1;
+ err = shell_quiet("which rawtherapee 1>2 2>/dev/null"); // check for Raw Therapee
+@@ -421,10 +421,10 @@
+ if (! err) PTtools = 2;
+ }
+
+- if (Fexiftool + Fxdgopen + Fleafpad < 3) { // check mandatory dependencies
++ if (Fexiftool + Fxdgopen + Ftexteditor < 3) { // check mandatory dependencies
+ strcpy(badnews,ZTX("Please install missing programs:"));
+ if (! Fexiftool) strcat(badnews,"\n exiftool 8.6 or later"); // refuse to start if any missing
+- if (! Fleafpad) strcat(badnews,"\n leafpad"); // 17.04
++ if (! Ftexteditor) strcat(badnews,"\n define EDITOR variable"); // 17.04
+ if (! Fxdgopen) strcat(badnews,"\n xdg-utils");
+ zmessageACK(Mwin,badnews);
+ m_quit(0,0);