summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-12-22 12:00:33 -0500
committerGuillaume Horel2019-12-22 12:00:33 -0500
commita8ac2c687a557efe88fedc4002cc05842e84e353 (patch)
treecf044d0fc958e28547747eb89477ed776b639f33
parent8efd7653b3e763470c9d874a35671332224be879 (diff)
downloadaur-a8ac2c687a557efe88fedc4002cc05842e84e353.tar.gz
version bump
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c44268226d4d..6a32265aeaf7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,23 @@
pkgbase = flexisip
pkgdesc = A general purpose SIP proxy with media capabilities
- pkgver = 1.0.12
+ pkgver = 2.0.0
pkgrel = 1
url = http://flexisip.org
install = flexisip.install
arch = x86_64
license = AGPL3
makedepends = cmake
- makedepends = git
- depends = belle-sip-git
+ makedepends = xsd
+ depends = belle-sip>=4.3
depends = belr
depends = hiredis
- depends = mediastreamer-git
- depends = ortp-git
+ depends = mediastreamer>=4.3
depends = protobuf
depends = soci
- depends = sofia-sip-bc
- depends = unixodbc
- depends = xsd
- source = git+https://github.com/BelleDonneCommunications/flexisip.git
- sha256sums = SKIP
+ depends = sofia-sip-bc>=1.13.41bc
+ depends = xerces-c
+ source = flexisip-2.0.0.tar.gz::https://github.com/BelledonneCommunications/flexisip/archive/2.0.0-beta.tar.gz
+ sha256sums = 679ce09120143a4dc363a38e9e41bd469a8ac589867b7d233d9fb0b036107092
pkgname = flexisip
diff --git a/PKGBUILD b/PKGBUILD
index 92068d260eeb..a8578fbd3fb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=flexisip
-pkgver=1.0.12
+pkgver=2.0.0
pkgrel=1
pkgdesc="A general purpose SIP proxy with media capabilities"
arch=('x86_64')
url="http://flexisip.org"
license=('AGPL3')
groups=()
-depends=('belle-sip-git' 'belr' 'hiredis' 'mediastreamer-git' 'ortp-git' 'protobuf' 'soci' 'sofia-sip-bc' 'unixodbc' 'xsd')
-makedepends=('cmake' 'git')
+depends=('belle-sip>=4.3' 'belr' 'hiredis' 'mediastreamer>=4.3' 'protobuf' 'soci' 'sofia-sip-bc>=1.13.41bc' 'xerces-c')
+makedepends=('cmake' 'xsd')
install='flexisip.install'
-source=("git+https://github.com/BelleDonneCommunications/$pkgname.git")
+source=("flexisip-$pkgver.tar.gz::https://github.com/BelledonneCommunications/flexisip/archive/$pkgver-beta.tar.gz")
noextract=()
-sha256sums=('SKIP')
+sha256sums=('679ce09120143a4dc363a38e9e41bd469a8ac589867b7d233d9fb0b036107092')
build() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver-beta"
cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib \
-DENABLE_REDIS=YES \
-DENABLE_PROTOBUF=YES \
-DENABLE_PRESENCE=YES .
@@ -25,9 +24,10 @@ build() {
}
package() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver-beta"
make DESTDIR="$pkgdir/" install
- install -Dm0644 "scripts/flexisip.service" "$pkgdir/usr/lib/systemd/system/flexisip.service"
- install -Dm0644 "scripts/flexisip-presence.service" "$pkgdir/usr/lib/systemd/system/flexisip.service"
+ for S in 'flexisip-presence' "flexisip-presence@" "flexisip-proxy" "flexisip-proxy@"; do
+ install -Dm0644 "scripts/$S.service" "$pkgdir/usr/lib/systemd/system/$S.service"
+ done;
}