summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2021-08-12 13:29:20 +0200
committerPellegrino Prevete2021-08-12 13:29:20 +0200
commita8bc41f3d2342c8a9eb2d8e74097f40357546707 (patch)
tree79d6673c614276da71852153b724349c14a2b266
parent8b9be30ceede3ab3b5f5d9e0bfaea50ab1e9f27b (diff)
downloadaur-a8bc41f3d2342c8a9eb2d8e74097f40357546707.tar.gz
0.9: fix pylint
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5378d03f530a..f3ac479698d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = power-profiles-daemon
pkgdesc = Makes power profiles handling available over D-Bus
pkgver = 0.9.0
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.freedesktop.org/hadess/power-profiles-daemon
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 9eabcb5629de..29eb4bd0e0e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,8 @@
+# Contributor: tinywrkb <tinywrkb@gmail.com>
+
pkgname=power-profiles-daemon
pkgver=0.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="Makes power profiles handling available over D-Bus"
url="https://gitlab.freedesktop.org/hadess/power-profiles-daemon"
license=(GPL3)
@@ -17,6 +19,12 @@ pkgver() {
git describe --tags | sed 's/-/+/g'
}
+ prepare() {
+ cd $pkgname
+ # fixes pylint test
+ git cherry-pick -n 42b3341b29047489ea5eecaf8cf7d6e74a228891
+ }
+
build() {
arch-meson $pkgname build
meson compile -C build