summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraeme Gott2023-01-10 13:39:37 -0500
committerGraeme Gott2023-01-10 13:39:37 -0500
commita8d9263220045a354ad85b6e582275e2b5d5208f (patch)
treeb488880d20bd0b8bf7a7f3ec966d2cb06dd1ac4a
parent4fd63fb8c64cfbf6f4698d8c2572b945fa6d7753 (diff)
downloadaur-a8d9263220045a354ad85b6e582275e2b5d5208f.tar.gz
Update to 1.4.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c99f5886a53c..868cc1019085 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = simsu
- pkgdesc = A basic Sudoku game
- pkgver = 1.4.1
+ pkgdesc = Basic Sudoku game
+ pkgver = 1.4.2
pkgrel = 1
url = https://gottcode.org/simsu/
arch = x86_64
@@ -8,7 +8,7 @@ pkgbase = simsu
makedepends = cmake
makedepends = qt6-tools
depends = qt6-base
- source = https://gottcode.org/simsu/simsu-1.4.1-src.tar.bz2
- sha256sums = 53ae023270336eefa3fe936671fb910d7cfbad8d6b898cef13260861d573e9ff
+ source = https://gottcode.org/simsu/simsu-1.4.2.tar.bz2
+ sha256sums = 7230293d7ff8d52b4a8d7f4e26638cff6e22e2a78edcc4ddaf7988da624fb37c
pkgname = simsu
diff --git a/PKGBUILD b/PKGBUILD
index cf573a45ce51..ada97a0dceee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: Graeme Gott <graeme@gottcode.org>
pkgname=simsu
-pkgver=1.4.1
+pkgver=1.4.2
pkgrel=1
-pkgdesc='A basic Sudoku game'
+pkgdesc='Basic Sudoku game'
arch=('x86_64')
-url="https://gottcode.org/$pkgname/"
+url="https://gottcode.org/${pkgname}/"
license=('GPL3')
depends=('qt6-base')
makedepends=('cmake' 'qt6-tools')
-source=("https://gottcode.org/$pkgname/$pkgname-$pkgver-src.tar.bz2")
-sha256sums=('53ae023270336eefa3fe936671fb910d7cfbad8d6b898cef13260861d573e9ff')
+source=("https://gottcode.org/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('7230293d7ff8d52b4a8d7f4e26638cff6e22e2a78edcc4ddaf7988da624fb37c')
build() {
- cmake -B build -S $pkgbase-$pkgver \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr
+ cmake -B build -S "${pkgname}-${pkgver}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
cmake --build build
}