summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-01-18 01:56:23 +0100
committerNarrat2020-01-18 01:56:23 +0100
commita8e09a4c5c95316529fce2d92838083cc8dabb92 (patch)
tree8682a05d03217f5402b1851bf1e5ca5ad77e674c
parent29f1c330e319368eaece1fc596f67d07bfdd4158 (diff)
downloadaur-a8e09a4c5c95316529fce2d92838083cc8dabb92.tar.gz
update to 0.2.9
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 24 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0ca793d5818..34a548266d1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-easyprocess
- pkgdesc = EasyProcess is an easy to use python subprocess interface.
- pkgver = 0.2.3
+ pkgdesc = easy to use python subprocess interface
+ pkgver = 0.2.9
pkgrel = 1
- url = https://pypi.python.org/pypi/EasyProcess
+ url = https://github.com/ponty/EasyProcess
arch = any
license = BSD
- depends = python>=3.2
+ depends = python
depends = python-setuptools
- source = https://pypi.python.org/packages/0d/f1/d2de7591e7dfc164d286fa16f051e6c0cf3141825586c3b04ae7cda7ac0f/EasyProcess-0.2.3.tar.gz
- md5sums = d08c91cbb2cc4603297968e1ed9eac0f
+ source = https://files.pythonhosted.org/packages/source/E/EasyProcess/EasyProcess-0.2.9.tar.gz
+ md5sums = a1008fc7b2cb69ff2f48a5fae201c24d
pkgname = python-easyprocess
diff --git a/PKGBUILD b/PKGBUILD
index d6d63f5ec54d..3cbbd410e2c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,25 @@
-# Maintainer: Michael Spradling <mike@mspradling.com>
+# Contributor: Lex Black <autumn-wind@web.de>
+# Contributor: Michael Spradling <mike@mspradling.com>
+
+_name=EasyProcess
pkgname=python-easyprocess
-pkgver=0.2.3
+pkgver=0.2.9
pkgrel=1
-pkgdesc="EasyProcess is an easy to use python subprocess interface."
+pkgdesc="easy to use python subprocess interface"
arch=(any)
-url="https://pypi.python.org/pypi/EasyProcess"
+url="https://github.com/ponty/EasyProcess"
license=('BSD')
-depends=('python>=3.2' 'python-setuptools')
-source=(https://pypi.python.org/packages/0d/f1/d2de7591e7dfc164d286fa16f051e6c0cf3141825586c3b04ae7cda7ac0f/EasyProcess-${pkgver}.tar.gz)
-md5sums=('d08c91cbb2cc4603297968e1ed9eac0f')
+depends=('python' 'python-setuptools')
+source=(https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz)
+md5sums=('a1008fc7b2cb69ff2f48a5fae201c24d')
+
+
+build() {
+ cd "${_name}-${pkgver}"
+ python setup.py build
+}
package() {
- cd "${srcdir}/EasyProcess-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 || exit 1
+ cd "${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}