summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarcnmx2017-12-11 12:02:16 -0500
committerarcnmx2017-12-11 12:02:16 -0500
commita9072a02db9db82434f60bf1e139387bf6f5d6e6 (patch)
treedc94aa7cfa92dc8084fa322efe444dd50eef4c92
parente10c12c72a0a70926d8b0a0eee8a9ab0f857d843 (diff)
downloadaur-a9072a02db9db82434f60bf1e139387bf6f5d6e6.tar.gz
include version in downloaded filenames
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.gitignore b/.gitignore
index 2d5adc6f4939..8cc2bb7574bb 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
/src/
/pkg/
-/passff.json
-/passff.py
+/passff*.json
+/passff*.py
/*.pkg*
diff --git a/PKGBUILD b/PKGBUILD
index 3fa1a9808ff5..739ce4992145 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@ license=(GPL2)
depends=(python)
arch=(i686 x86_64)
source=(
- https://github.com/passff/passff/releases/download/$pkgver/passff.py
- https://github.com/passff/passff/releases/download/$pkgver/passff.json
+ passff-$pkgver.py::https://github.com/passff/passff/releases/download/$pkgver/passff.py
+ passff-$pkgver.json::https://github.com/passff/passff/releases/download/$pkgver/passff.json
)
_native_messaging=(
@@ -21,16 +21,16 @@ _native_messaging=(
_bindir="/usr/lib/passff"
build() {
- sed -i -e "s-PLACEHOLDER-$_bindir/passff.py-" "$srcdir/passff.json"
+ sed -i -e "s-PLACEHOLDER-$_bindir/passff.py-" "$srcdir/passff-$pkgver.json"
}
package() {
install -d "$pkgdir$_bindir"
- install -m 0755 "$srcdir/passff.py" "$pkgdir$_bindir/"
+ install -m 0755 "$srcdir/passff-$pkgver.py" "$pkgdir$_bindir/passff.py"
for d in "${_native_messaging[@]}"; do
install -d "$pkgdir$d"
- install -m 0644 "$srcdir/passff.json" "$pkgdir$d/"
+ install -m 0644 "$srcdir/passff-$pkgver.json" "$pkgdir$d/passff.json"
done
}