summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Phillips2018-12-17 20:28:43 -0800
committerJulian Phillips2018-12-17 20:28:43 -0800
commita9a6d6209586498ffd580e57b32bfe1dce4354f6 (patch)
tree208a51f5b453093135c7b40a96307d5fc0a9016f
parentc5108618434a7f01f6e80cadd11b1050f36d407a (diff)
downloadaur-a9a6d6209586498ffd580e57b32bfe1dce4354f6.tar.gz
Updated patch checksum. Removed explicit base-devel deps.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7af4449bbbe8..d38ead5c628c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sos
pkgdesc = A unified tool for collecting system logs and other debug information
pkgver = 3.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sosreport/sos
arch = any
license = GPL2
@@ -11,13 +11,11 @@ pkgbase = sos
depends = python
depends = python-six
depends = python-lxml
- depends = xz
- depends = tar
backup = etc/sos.conf
source = https://github.com/sosreport/sos/archive/3.6.tar.gz
source = https://patch-diff.githubusercontent.com/raw/sosreport/sos/pull/1198.patch
sha256sums = 0e19b80e307140a3af78adb2fe5b821ab3c8fc6fb63d3851c78ef83de2680fd3
- sha256sums = 1b15996a9d15ff461b7b939eb8982b21b2dc508d973aa4833886c5c5a97d9470
+ sha256sums = 10478856a9edd42a32d52c1af1b65c86532aed8c0f5b892ce531fb8d3cb41759
pkgname = sos
diff --git a/PKGBUILD b/PKGBUILD
index 123a9fae5d33..47280a11dfad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: chr0mag <phillips.julian AT gmail DOT com>
pkgname=sos
pkgver=3.6
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="A unified tool for collecting system logs and other debug information"
arch=('any')
@@ -10,11 +10,10 @@ license=('GPL2')
groups=()
depends=('python'
'python-six'
- 'python-lxml'
- 'xz'
- 'tar')
+ 'python-lxml')
makedepends=('python-sphinx')
-checkdepends=('python-nose' 'python-coverage')
+checkdepends=('python-nose'
+ 'python-coverage')
optdepends=()
provides=()
conflicts=()
@@ -30,13 +29,13 @@ source=("https://github.com/sosreport/sos/archive/$pkgver.tar.gz"
noextract=()
md5sums=()
sha256sums=('0e19b80e307140a3af78adb2fe5b821ab3c8fc6fb63d3851c78ef83de2680fd3'
- '1b15996a9d15ff461b7b939eb8982b21b2dc508d973aa4833886c5c5a97d9470')
+ '10478856a9edd42a32d52c1af1b65c86532aed8c0f5b892ce531fb8d3cb41759')
validpgpkeys=()
prepare() {
cd "$pkgname-$pkgver"
- patch --strip=1 < ../../$_archpullreq
+ patch --strip=1 < ../$_archpullreq
}
build() {
@@ -51,9 +50,10 @@ check() {
package() {
cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ make DESTDIR="$pkgdir" install
#put binary in /usr/bin instead of /usr/sbin
mkdir ${pkgdir}/usr/bin
mv ${pkgdir}/usr/sbin/sosreport ${pkgdir}/usr/bin
- rmdir ${pkgdir}/usr/sbin
+ rmdir ${pkgdir}/usr/sbin
+ #rmdir ${pkgdir}/usr/share/doc/sos ${pkgdir}/usr/share/sos/extras
}