summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoey Dumont2020-10-22 22:13:00 -0400
committerJoey Dumont2020-10-22 22:13:00 -0400
commita9a73de8e7fc62edce66aea03e9d74a3407480d3 (patch)
treeffa8082e780122ed51c7b45619fdae56d450cfb5
parent7845e8e6ff4681fc7b54f7e19ff7aaacd70def59 (diff)
downloadaur-a9a73de8e7fc62edce66aea03e9d74a3407480d3.tar.gz
Fixed build by adding glslang.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d620e3a08ae..c42ad82eddbb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = snes9x-git
pkgdesc = Port of the Snes9x emulator (git version)
- pkgver = 1.59.2.r33.gc39f769
+ pkgver = 1.60.r280.gfc78065
pkgrel = 1
url = http://www.snes9x.com/
arch = x86_64
@@ -29,6 +29,8 @@ pkgbase = snes9x-git
makedepends = zlib
source = git+https://github.com/snes9xgit/snes9x.git
source = git+https://github.com/KhronosGroup/SPIRV-Cross.git
+ source = git+https://github.com/KhronosGroup/glslang.git
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 39de18d9e041..7e3bf401828b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: LIN Ruohshoei <lin dot ruohshoei+arch at gmail dot com>
+# Maintainer: Joey Dumont <joey.dumont@gmail.com>
+# Contributor: LIN Ruohshoei <lin dot ruohshoei+arch at gmail dot com>
# Contributor: Michael DeGuzis <mdeguzis@gmail.com>
pkgbase=snes9x-git
_pkgbase=snes9x
pkgname=( snes9x-git snes9x-gtk-git )
-pkgver=1.59.2.r33.gc39f769
+pkgver=1.60.r280.gfc78065
pkgrel=1
pkgdesc="Port of the Snes9x emulator (git version)"
arch=('x86_64')
@@ -17,8 +18,10 @@ makedepends=( alsa-lib cairo gdk-pixbuf2 git glib2 glslang
source=(
git+https://github.com/snes9xgit/snes9x.git
git+https://github.com/KhronosGroup/SPIRV-Cross.git
+ git+https://github.com/KhronosGroup/glslang.git
)
sha256sums=('SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -34,6 +37,12 @@ prepare() {
git submodule update ${submodule}
done
+ for submodule in shaders/glslang; do
+ git submodule init ${submodule}
+ git config submodule.${submodule}.url ../${submodule#*/}
+ git submodule update ${submodule}
+ done
+
cd unix
autoreconf -fiv
}