summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-06-08 14:52:45 +0200
committerbartus2021-06-08 14:53:26 +0200
commita9b9d22475438e8ff23291b73049d9c1221a1eb9 (patch)
tree55c6c58020dd448e0ef219f943a95a71f2028630
parentb066245eb6e752db976e987d9caaab954c5b8a9c (diff)
downloadaur-a9b9d22475438e8ff23291b73049d9c1221a1eb9.tar.gz
Pop version to v6.0.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--fsi.patch17
-rw-r--r--thrust.patch15
4 files changed, 29 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef04810d704e..41a1a9b73e97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chronoengine
pkgdesc = An Open Source Multi-physics Simulation Engine
- pkgver = 5.0.1
+ pkgver = 6.0.0
pkgrel = 1
url = https://projectchrono.org/
arch = i686
@@ -19,7 +19,7 @@ pkgbase = chronoengine
makedepends = gcc-fortran
makedepends = python
makedepends = swig
- makedepends = cuda<=10.2.89
+ makedepends = cuda
makedepends = blaze
makedepends = oce
makedepends = mumps
@@ -29,6 +29,7 @@ pkgbase = chronoengine
depends = blas
depends = boost-libs
depends = hdf5
+ depends = opencrg
optdepends = irrlicht: Runtime visualization with Irrlicht.
optdepends = glew: Runtime visualization with OpenGL.
optdepends = glfw: Runtime visualization with OpenGL.
@@ -37,18 +38,17 @@ pkgbase = chronoengine
optdepends = nvidia-utils: CUDA support in PARALLEL module
optdepends = opencascade: add 3D CAD file support (STEP format)
optdepends = intel-mkl: This library is currently used in Chrono for its parallel direct solver (Pardiso)
- source = chronoengine::git+https://github.com/projectchrono/chrono.git#tag=5.0.1
+ source = chronoengine::git+https://github.com/projectchrono/chrono.git#tag=6.0.0
source = git+https://github.com/google/benchmark.git
source = git+https://github.com/google/googletest.git
source = chronoengine.sh
source = glm.patch
- source = fsi.patch
+ source = thrust.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 0fe883cfcc1db869d08235482a3801fa458db15360e0eefac9084c7f2993af4a
sha256sums = 4e8ed0097fb14bbe437c2a57e9ef1852fdbfe8675e5345b0af42287d24fbfefe
- sha256sums = 30b72d0004f784950ef8496a10cc491de8d98a855c6db97ac8fe2e73d01c1579
+ sha256sums = bf9717a2a1d569e376623d40e9b83fb766629a9ef9acc16e4af5358132202526
pkgname = chronoengine
-
diff --git a/PKGBUILD b/PKGBUILD
index 8b0cffb55350..3e7532d0f99b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,19 +5,20 @@
# MUMPS need some work to be able to link corectly with deps of mumps (scotch,mpi)
pkgname=chronoengine
-pkgver=5.0.1
+pkgver=6.0.0
_fragment="#tag=${pkgver}"
pkgrel=1
pkgdesc="An Open Source Multi-physics Simulation Engine"
license=('custom')
arch=('i686' 'x86_64')
url="https://projectchrono.org/"
-depends=(openmpi blas boost-libs hdf5)
+depends=(openmpi blas boost-libs hdf5 opencrg)
makedepends+=(cmake eigen git boost glm glew glfw irrlicht glut openmpi gcc-fortran)
makedepends+=(python swig) # MODULE_PYTHON
-makedepends+=('cuda<=10.2.89') # MODULE_GRANULAR
+makedepends+=(cuda) # MODULE_GRANULAR
# MODULE_PARALLEL optional
makedepends+=(blaze) # MODULE_PARALLEL required
+#makedepends+=(thrust) # MODULE_PARALLEL required (included in cuda)
#makedepends+=(opencascade)# MODULE_CASCADE (version<=7.2)
# use oce (opencascade comunitiy edition)
makedepends+=(oce) # MODULE_CASCADE
@@ -38,16 +39,17 @@ source=("${pkgname}::git+https://github.com/projectchrono/chrono.git${_fragment}
"git+https://github.com/google/googletest.git"
"chronoengine.sh"
"glm.patch"
- "fsi.patch"
+ "thrust.patch"
)
sha256sums=('SKIP'
'SKIP'
'SKIP'
'0fe883cfcc1db869d08235482a3801fa458db15360e0eefac9084c7f2993af4a'
'4e8ed0097fb14bbe437c2a57e9ef1852fdbfe8675e5345b0af42287d24fbfefe'
- '30b72d0004f784950ef8496a10cc491de8d98a855c6db97ac8fe2e73d01c1579')
+ 'bf9717a2a1d569e376623d40e9b83fb766629a9ef9acc16e4af5358132202526')
CMAKE_FLAGS=( -DENABLE_MODULE_POSTPROCESS=ON
+ -DENABLE_OPENCRG=ON
-DENABLE_HDF5=ON
-DENABLE_MODULE_VEHICLE=ON
-DENABLE_MODULE_PYTHON=ON
@@ -79,7 +81,7 @@ prepare() {
sed -i 's/lib64/lib/' "${files[@]}"
sed -i 's|share/chrono/bin|bin/chronoengine|' CMakeLists.txt
git apply -v "${srcdir}"/glm.patch
- git apply -v "${srcdir}"/fsi.patch
+# git apply -v "${srcdir}"/thrust.patch
}
build() {
diff --git a/fsi.patch b/fsi.patch
deleted file mode 100644
index 7870f7152f32..000000000000
--- a/fsi.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/src/chrono_fsi/CMakeLists.txt b/src/chrono_fsi/CMakeLists.txt
-index c31c1671f..376920c66 100644
---- a/src/chrono_fsi/CMakeLists.txt
-+++ b/src/chrono_fsi/CMakeLists.txt
-@@ -167,12 +167,6 @@ if(ENABLE_MODULE_PARALLEL)
- list(APPEND LIBRARIES ChronoEngine_parallel)
- endif()
-
--if(ENABLE_MODULE_FEA)
-- set(CXX_FLAGS ${CH_FEA_CXX_FLAGS})
-- include_directories(${CH_FEA_INCLUDES})
-- list(APPEND LIBRARIES ChronoEngine_fea)
--endif()
--
- if(ENABLE_MODULE_VEHICLE)
- include_directories(${CH_VEHICLE_INCLUDES})
- list(APPEND LIBRARIES ChronoEngine_vehicle)
diff --git a/thrust.patch b/thrust.patch
new file mode 100644
index 000000000000..f83b97b9efe6
--- /dev/null
+++ b/thrust.patch
@@ -0,0 +1,15 @@
+diff --git a/cmake/FindThrust.cmake b/cmake/FindThrust.cmake
+index d1fb58f37..2b6a6d03d 100644
+--- a/cmake/FindThrust.cmake
++++ b/cmake/FindThrust.cmake
+@@ -67,5 +67,8 @@ find_package_handle_standard_args( Thrust
+ VERSION_VAR THRUST_VERSION
+ )
+
++# Append cuda dir
++list(APPEND THRUST_INCLUDE_DIR "/opt/cuda/targets/x86_64-linux/include")
++
+ set(THRUST_INCLUDE_DIRS ${THRUST_INCLUDE_DIR})
+-mark_as_advanced(THRUST_INCLUDE_DIR)
+\ No newline at end of file
++mark_as_advanced(THRUST_INCLUDE_DIR)