summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCoelacanthus2020-04-10 07:51:56 +0800
committerCoelacanthus2020-04-10 07:51:56 +0800
commita9c5b532749378d3a4a20d014d70d207cade870c (patch)
tree17ece8711f99bcc6a99a0b0f0cdad8b31e297d1a
downloadaur-a9c5b532749378d3a4a20d014d70d207cade870c.tar.gz
Init
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD46
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ffc029eee8e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = librime-lua-git
+ pkgdesc = Rime input method engine with Lua plugin
+ pkgver = 1.5.3.r74.f215a04
+ pkgrel = 1
+ url = https://github.com/hchunhui/librime-lua
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = boost
+ makedepends = gtest
+ depends = boost-libs
+ depends = opencc
+ depends = yaml-cpp
+ depends = leveldb
+ depends = librime-data
+ depends = google-glog
+ depends = marisa
+ depends = lua
+ provides = librime
+ conflicts = librime
+ conflicts = librime-lua
+ source = git+https://github.com/hchunhui/librime-lua.git
+ source = librime-1.5.3.tar.gz::https://github.com/rime/librime/archive/1.5.3.tar.gz
+ sha512sums = SKIP
+ sha512sums = 4d7f6ec43bd5728f59f0b3581bcd8a46128651430b6873017d80659942b8f6aa1a2f25f439ba8fba461fe22acbf701c2da7a786104a2e4852a70a89cdc0452d3
+
+pkgname = librime-lua-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33cd577b04db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Coelacanthus <liuhongwu2003@outlook.com>
+
+pkgname=librime-lua-git
+_pkgname=librime
+pkgver=1.5.3.r74.f215a04
+_pkgver=1.5.3
+pkgrel=1
+pkgdesc="Rime input method engine with Lua plugin"
+arch=('x86_64')
+url="https://github.com/hchunhui/librime-lua"
+license=('GPL3')
+depends=('boost-libs' 'opencc' 'yaml-cpp' 'leveldb' 'librime-data' 'google-glog' 'marisa' 'lua')
+makedepends=('git' 'cmake' 'boost' 'gtest')
+provides=('librime')
+conflicts=('librime' 'librime-lua')
+source=("git+https://github.com/hchunhui/librime-lua.git"
+ "$_pkgname-$_pkgver.tar.gz::https://github.com/rime/librime/archive/$_pkgver.tar.gz"
+)
+sha512sums=('SKIP'
+ '4d7f6ec43bd5728f59f0b3581bcd8a46128651430b6873017d80659942b8f6aa1a2f25f439ba8fba461fe22acbf701c2da7a786104a2e4852a70a89cdc0452d3'
+)
+
+pkgver() {
+ cd librime-lua
+ printf "%s.r%s.%s" "$(echo $_pkgver)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cp -r librime-lua $_pkgname-$_pkgver/plugins/lua
+}
+
+build() {
+ cd $_pkgname-$_pkgver
+ #cmake . -Bbuild -DCMAKE_INSTALL_PREFIX=/usr
+ #cmake --build build
+ cmake . -Bbuild \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_MERGED_PLUGINS=ON
+ cmake --build build
+}
+
+package() {
+ cd $_pkgname-$_pkgver/build
+ make DESTDIR="$pkgdir" install
+}