summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChugunov Roman2023-11-17 13:18:46 +0300
committerChugunov Roman2023-11-17 13:18:46 +0300
commita9c6b61e54775478a4624ba57a0a1785eaa3bc5d (patch)
treef882b617b3c23856d9969a9402226ae509fea6d8
parent85ed343c94f29afc37378147bf29169f729c821f (diff)
downloadaur-a9c6b61e54775478a4624ba57a0a1785eaa3bc5d.tar.gz
choreL prepare repo to update from CI
-rw-r--r--PKGBUILD2
-rw-r--r--current_version1
-rwxr-xr-xupdate_package28
3 files changed, 1 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f591a3837378..65bdd1384fc8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
## Maintainer: Speykious <speykious@gmail.com>
pkgname=figma-linux-bin
-_pkgver=`cat current_version`
+_pkgver="0.10.0"
_appimage="figma-linux_${_pkgver}_linux_x86_64.AppImage"
pkgver=`echo "$_pkgver" | tr '\\:/\- ' '_'`
pkgrel=2
diff --git a/current_version b/current_version
deleted file mode 100644
index 78bc1abd14f2..000000000000
--- a/current_version
+++ /dev/null
@@ -1 +0,0 @@
-0.10.0
diff --git a/update_package b/update_package
deleted file mode 100755
index 920276876ca3..000000000000
--- a/update_package
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/bin/bash
-
-C="\x1b[0m"
-GRN="\x1b[32m"
-YEL="\x1b[33m"
-BLU="\x1b[34m"
-col2="$BLU::$C"
-
-url=https://github.com/Figma-linux/figma-linux
-current=`cat current_version`
-echo -e "$col2 Getting latest version..." >/dev/stderr
-_latest=`basename $(curl -Ls -o /dev/null -w %{url_effective} "$url/releases/latest")`
-latest="${_latest:1}"
-
-if [ "$current" = "$latest" ] && [ "$1" != "-f" ]; then
- echo -e "$col2 Current $GRN$current$C is latest, no update required" >/dev/stderr
-else
- echo -e "$col2 Changing current version from $YEL$current$C to $GRN$latest$C"
- echo "$latest" > current_version
-fi
-
-echo -e "$col2 Writing .SRCINFO file..."
-makepkg --printsrcinfo > .SRCINFO
-
-echo -e "$col2 Updating checksums..."
-updpkgsums
-
-echo -e "$col2 Done"