summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-04 15:32:44 +0300
committerDimitris Kiziridis2020-04-04 15:32:44 +0300
commita9d71f6a8828559e8895bc4778ce6c65ecdc38dc (patch)
tree866279cb252f8646d14f2d04ad663bb107c6fa8c
parent2fec9570432501f2e2fdcbb5ec5334cc51283042 (diff)
downloadaur-a9d71f6a8828559e8895bc4778ce6c65ecdc38dc.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d82f40789449..bcb74a1d04dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = asciigraph
pkgdesc = Go package to make lightweight ASCII line graph ╭┈╯ in command line apps with no other dependencies
pkgver = 0.4.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/guptarohit/asciigraph
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 5fdde631a128..ea0c715ad704 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=asciigraph
pkgver=0.4.1
-pkgrel=2
+pkgrel=3
pkgdesc="Go package to make lightweight ASCII line graph ╭┈╯ in command line apps with no other dependencies"
arch=('x86_64')
url='https://github.com/guptarohit/asciigraph'
@@ -11,12 +11,17 @@ makedepends=('go')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/guptarohit/asciigraph/archive/v0.4.1.tar.gz")
md5sums=('6efaf8b04f7f55e4863ce3127aa2308c')
-build() {
+prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
mkdir -p $srcdir/go
export GOPATH="${srcdir}"/go
export PATH=$PATH:$GOPATH/bin
go get -d -v ./...
+}
+
+build() {
+ export GOPATH="${srcdir}"/go
+ export PATH=$PATH:$GOPATH/bin
cd "${srcdir}/${pkgname}-${pkgver}/cmd/asciigraph"
go build -v -o "${srcdir}/asciigraph-bin"
}