summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornemaeon2016-10-19 17:31:02 -0400
committernemaeon2016-10-19 17:31:02 -0400
commita9d876724ca649cfb5a5d7438a510807342e1d29 (patch)
tree1dfe91eced9325154ad510ebd40e5e5e2bbea40b
parent7d22e5e8a89b8ae170fa10da6a4bbf2f512bcefb (diff)
downloadaur-a9d876724ca649cfb5a5d7438a510807342e1d29.tar.gz
Update with patch to fix freetype2 for compilation success.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--freetype2.patch26
3 files changed, 39 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9434ebe4ab4..69d89c765d37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Oct 19 20:03:03 UTC 2016
+# Wed Oct 19 21:30:43 UTC 2016
pkgbase = fbsplash
pkgdesc = Userspace splash screen implementation (formerly 'gensplash') (deprecated, see: Plymouth)
pkgver = 1.5.4.4
- pkgrel = 16
+ pkgrel = 17
url = http://sourceforge.net/projects/fbsplash.berlios/
install = fbsplash.install
arch = i686
@@ -33,6 +33,7 @@ pkgbase = fbsplash
source = fbsplash.initcpio_hook
source = fbcondecor.daemon
source = fbcondecor.conf
+ source = freetype2.patch
md5sums = 2a16704c4adde97b58812cd89e3f2342
md5sums = 4045e315c52f5a576fca4f7e634eeb91
md5sums = 90708a96038d7d7921c2e9fde938c058
@@ -41,6 +42,7 @@ pkgbase = fbsplash
md5sums = f65cf94d4d4959bb44cda5fa634ab405
md5sums = 631b10db2f7c4b70062e79b60541ddbb
md5sums = b3db9d4fd902b62ac9e38589677e2d16
+ md5sums = b3da198e805a988b62d70a2dd6895384
pkgname = fbsplash
diff --git a/PKGBUILD b/PKGBUILD
index ffe8018a95a5..577d65c61e08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=fbsplash
pkgver=1.5.4.4
-pkgrel=16
+pkgrel=17
pkgdesc="Userspace splash screen implementation (formerly 'gensplash') (deprecated, see: Plymouth)"
arch=('i686' 'x86_64')
url="http://sourceforge.net/projects/fbsplash.berlios/"
@@ -25,7 +25,8 @@ source=("http://heanet.dl.sourceforge.net/project/fbsplash.berlios/splashutils-1
'fbsplash.initcpio_install'
'fbsplash.initcpio_hook'
'fbcondecor.daemon'
- 'fbcondecor.conf')
+ 'fbcondecor.conf'
+ 'freetype2.patch')
md5sums=('2a16704c4adde97b58812cd89e3f2342'
'4045e315c52f5a576fca4f7e634eeb91'
'90708a96038d7d7921c2e9fde938c058'
@@ -33,7 +34,8 @@ md5sums=('2a16704c4adde97b58812cd89e3f2342'
'2860cc29d5da2ea65c810de068bcc262'
'f65cf94d4d4959bb44cda5fa634ab405'
'631b10db2f7c4b70062e79b60541ddbb'
- 'b3db9d4fd902b62ac9e38589677e2d16')
+ 'b3db9d4fd902b62ac9e38589677e2d16'
+ 'b3da198e805a988b62d70a2dd6895384')
build() {
cd splashutils-$pkgver
@@ -61,8 +63,10 @@ build() {
#Fix freetype => freetype2
sed -i 's|\(#include <freetype\)/|\12/|' src/libfbsplashrender.c
- sed -i 's|\(#include <freetype\)/|\12/|' src/ttf.h
- sed -i 's|\(#include <freetype\)/|\12/|' src/ttf.c
+
+ patch -Np2 -i "$srcdir/freetype2.patch"
+# sed -i 's|\(#include <freetype\)/|\12/|' src/ttf.h
+# sed -i 's|\(#include <freetype\)/|\12/|' src/ttf.c
# fix set_event_dev call for initcpio usage (if evdev module is there)
#patch -Np2 -i "$srcdir/splash_start_initcpio.patch"
diff --git a/freetype2.patch b/freetype2.patch
new file mode 100644
index 000000000000..c073c2dcc7cd
--- /dev/null
+++ b/freetype2.patch
@@ -0,0 +1,26 @@
+--- a/splashutils-1.5.4.4/src/ttf.c
++++ b/splashutils-1.5.4.4/src/ttf.c
+@@ -27,8 +27,8 @@
+ #include <assert.h>
+
+ #include <ft2build.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/ttnameid.h>
++#include FT_OUTLINE_H
++#include FT_TRUETYPE_IDS_H
+
+ #include "splash.h"
+
+--- a/splashutils-1.5.4.4/src/ttf.h
++++ b/splashutils-1.5.4.4/src/ttf.h
+@@ -1,8 +1,8 @@
+ #ifndef _TTF_H
+ #define _TTF_H
+ #include <ft2build.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/ttnameid.h>
++#include FT_OUTLINE_H
++#include FT_TRUETYPE_IDS_H
+
+ #define CACHED_METRICS 0x10
+ #define CACHED_BITMAP 0x01