summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Bocken2024-03-24 10:37:02 +0100
committerAlexander Bocken2024-03-24 10:37:02 +0100
commita9d9fc8bcdac7af123c2c6f02adfe1c8451f8505 (patch)
tree30f39e18e06b1830a71202f23b6cb9a541f8da0f
parent76d57e5179a108efd37485c37be86544ab08a3f5 (diff)
downloadaur-a9d9fc8bcdac7af123c2c6f02adfe1c8451f8505.tar.gz
bump pkgver to ensure correct build against current svt-av1, remove mold as linker for lto
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 613d6912e52a..6d3ca7caf908 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = anki-qt5
pkgdesc = Helps you remember facts (like words/phrases in a foreign language) - Qt5 Build
pkgver = 23.12.1
- pkgrel = 1
+ pkgrel = 2
url = https://apps.ankiweb.net/
changelog = anki-qt5.changelog
arch = x86_64
@@ -14,7 +14,6 @@ pkgbase = anki-qt5
makedepends = python-wheel
makedepends = nodejs>=18
makedepends = yarn
- makedepends = mold
depends = python>=3.9
depends = python-beautifulsoup4
depends = python-waitress>=2.0.0
diff --git a/PKGBUILD b/PKGBUILD
index c06a1759f4cd..19097ce9794b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,7 @@ declare -gA _caches=(
pkgname=anki-qt5
pkgver=23.12.1
-pkgrel=1
+pkgrel=2
pkgdesc="Helps you remember facts (like words/phrases in a foreign language) - Qt5 Build"
url="https://apps.ankiweb.net/"
license=('AGPL3')
@@ -57,11 +57,10 @@ makedepends=(
'git'
'ninja'
'cargo'
- 'python-installer' # TODO: could use either wheel or installer, both are not needed afaik
+ 'python-installer'
'python-wheel'
'nodejs>=18'
'yarn'
- 'mold'
)
optdepends=(
'lame: record sound'
@@ -139,7 +138,10 @@ build() {
export CARGO_HOME="$srcdir/${_caches[cargo]}" # do not litter in ~
export RELEASE=2 # anki-internal variable for optimization
- mold -run ./ninja wheels -v # use mold as linker to allow for LTO
+ # use fat LTO objects, allows for LTO, needed for rust crate "ring"
+ # See https://gitlab.archlinux.org/archlinux/packaging/packages/pacman/-/issues/20 and https://github.com/briansmith/ring/issues/1444
+ export CFLAGS+=' -ffat-lto-objects'
+ ./ninja wheels -v
}
package() {