summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Band2024-04-15 11:02:18 +0200
committerRicardo Band2024-04-15 11:02:18 +0200
commita9efab9c5fbb60a06fd966c53f6d6a1c1b87a16f (patch)
treeec0a1cf2089137a8878b1811d55b0e03b10257be
parent89cafc2d792fc838c9131144eef17ba46e13c93e (diff)
downloadaur-a9efab9c5fbb60a06fd966c53f6d6a1c1b87a16f.tar.gz
remove poetry again
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8664bd22302c..74b5225b18ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = virtualfish
pkgdesc = Fish shell tool for managing Python virtual environments
pkgver = 2.5.7
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/justinmayer/virtualfish
arch = any
license = custom:MIT
- makedepends = python-poetry-core
+ makedepends = python-build
+ makedepends = python-wheel
makedepends = python-installer
depends = fish
depends = python-packaging
depends = python-pkgconfig
depends = python-psutil
depends = python-virtualenv
+ depends = python-setuptools
source = https://files.pythonhosted.org/packages/source/v/virtualfish/virtualfish-2.5.7.tar.gz
sha256sums = f507d8cd281cb1c1ebf6021fc18ac20a85d8afbfc5ea4fe8eb0a3f54349bc9ba
diff --git a/PKGBUILD b/PKGBUILD
index 3c55e0fbc205..7f58466f555b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,20 @@
# Maintainer: Ricardo Band <email@ricardo.band>
pkgname=virtualfish
pkgver=2.5.7
-pkgrel=3
+pkgrel=4
pkgdesc="Fish shell tool for managing Python virtual environments"
arch=("any")
url=https://github.com/justinmayer/virtualfish
license=("custom:MIT")
-depends=("fish" "python-packaging" "python-pkgconfig" "python-psutil" "python-virtualenv")
-makedepends=("python-poetry-core" "python-installer")
+depends=("fish" "python-packaging" "python-pkgconfig" "python-psutil" "python-virtualenv" "python-setuptools")
+makedepends=("python-build" "python-wheel" "python-installer")
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
sha256sums=('f507d8cd281cb1c1ebf6021fc18ac20a85d8afbfc5ea4fe8eb0a3f54349bc9ba')
-check() {
- cd "$srcdir/$pkgname-$pkgver"
-
- poetry check
-}
-
build() {
cd "$srcdir/$pkgname-$pkgver"
- poetry build --format wheel --output dist
+ pytthon -m build --wheel --no-isolation
}
package() {