summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralbfan2017-09-24 11:52:46 +0200
committeralbfan2017-09-24 11:52:46 +0200
commita9fb51fa78ab95ced3e6c5aadf134712d9354e21 (patch)
tree7b5764c014c074adef2f84af44508531f0deda6f
parent89c4b6ace5109b69cd5e0f01e3d63b68c01a9dc0 (diff)
downloadaur-a9fb51fa78ab95ced3e6c5aadf134712d9354e21.tar.gz
Update to meson buildsystem
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd6e997fec1a..b31fdfe251e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,10 @@
+# Generated by mksrcinfo v8
+# Sun Sep 24 09:51:32 UTC 2017
pkgbase = sysprof2-git
pkgdesc = CPU Profiler
- pkgver = 3.20.0.r25.gb97425b
+ pkgver = 3.26.0.r5.g00887d7
pkgrel = 1
- url = https://github.com/chergert/sysprof2
+ url = https://git.gnome.org/browse/sysprof
arch = i686
arch = x86_64
arch = armv6h
diff --git a/PKGBUILD b/PKGBUILD
index 2839fb3f1ff2..2750faeb74e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer: TingPing tingping@tingping.se
+# Maintainer: albfan albertofanjul@gmail.com
pkgname=sysprof2-git
-pkgver=3.20.0.r25.gb97425b
+pkgver=3.26.0.r5.g00887d7
pkgrel=1
pkgdesc='CPU Profiler'
arch=('i686' 'x86_64' 'armv6h')
-url='https://github.com/chergert/sysprof2'
+url='https://git.gnome.org/browse/sysprof'
license=('GPL3')
options=('!libtool')
depends=('gtk3' 'polkit')
@@ -24,12 +24,15 @@ pkgver() {
build() {
cd "$_gitname"
-
- ./autogen.sh --prefix=/usr --disable-debug
- make -s
+ rm -rf build
+ mkdir build
+ cd build
+ meson --prefix /usr ..
+ ninja
}
package() {
cd "$_gitname"
- make DESTDIR="$pkgdir" install
+ cd build
+ DESTDIR="$pkgdir" ninja install
}