summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrançois Boulogne2015-06-09 21:44:06 -0400
committerFrançois Boulogne2015-06-09 21:44:06 -0400
commitaa0344dea115d1576608f5dc85d737de28d23bc5 (patch)
treee5abc3163360f58db31fe4a725e329d63d99ca9d
downloadaur-aa0344dea115d1576608f5dc85d737de28d23bc5.tar.gz
Initial import
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
3 files changed, 60 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..d99de5a876c2
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = python-pyinsane
+ pkgdesc = Python implementation of the Sane API (using ctypes) and abstration layer
+ pkgver = 1.3.6
+ pkgrel = 1
+ url = https://github.com/jflesch/pyinsane
+ arch = any
+ license = GPL3
+ makedepends = python
+ makedepends = python-setuptools
+ depends = libksane
+ provides = python-pyinsane
+ conflicts = python-pyinsane
+ source = https://github.com/jflesch/pyinsane/archive/v1.3.6.zip
+
+pkgname = python-pyinsane
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b6b17dc4076
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-pyinsane
+ pkgdesc = Python implementation of the Sane API (using ctypes) and abstration layer
+ pkgver = 1.3.6
+ pkgrel = 1
+ url = https://github.com/jflesch/pyinsane
+ arch = any
+ license = GPL3
+ makedepends = python
+ makedepends = python-setuptools
+ depends = libksane
+ provides = python-pyinsane
+ conflicts = python-pyinsane
+ source = https://github.com/jflesch/pyinsane/archive/v1.3.6.zip
+ md5sums = a532a050638b2bef762a741ff91904e0
+
+pkgname = python-pyinsane
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44d7048ae8f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Francois Boulogne <fboulogne@april.org>
+
+pkgname=python-pyinsane
+pkgver=1.3.6
+pkgrel=1
+pkgdesc='Python implementation of the Sane API (using ctypes) and abstration layer'
+arch=('any')
+url='https://github.com/jflesch/pyinsane'
+license=('GPL3')
+depends=('libksane')
+provides=('python-pyinsane')
+conflicts=('python-pyinsane')
+makedepends=('python' 'python-setuptools')
+source=("https://github.com/jflesch/pyinsane/archive/v${pkgver}.zip")
+
+build() {
+ cd "pyinsane-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "pyinsane-${pkgver}"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+# vim:ts=2:sw=2:et:
+md5sums=('a532a050638b2bef762a741ff91904e0')