summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Roberts2019-02-26 12:20:57 +0000
committerPeter Roberts2019-02-26 12:20:57 +0000
commitaa05fa6003bfadd0e3c6bd67b187f06e98aff3f9 (patch)
tree5a8ad0d6180ccf0a79d944ea83b2897104714d69
parent5638e549c8627dea26aefe77a7b40a057f8f60f2 (diff)
downloadaur-aa05fa6003bfadd0e3c6bd67b187f06e98aff3f9.tar.gz
Fix an errant hyphen in ldflags
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 854c105c75d5..e37419df5e54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zoom-parallel
pkgdesc = Parallel command executor with a focus on simplicity and good cross-platform behaviour
pkgver = 0.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pwr22/zoom
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 3072958bc235..52f6548b3728 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Peter Roberts <me@peter-r.co.uk>
pkgname=zoom-parallel
pkgver=0.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Parallel command executor with a focus on simplicity and good cross-platform behaviour "
arch=("x86_64")
url="https://github.com/pwr22/zoom"
@@ -20,7 +20,7 @@ prepare(){
ln -rTsf "$_cmdname-$pkgver" "go/src/github.com/pwr22/$_cmdname"
export GOPATH="$srcdir/go"
- export GOFLAGS="-gcflags=all=-trimpath=$PWD -asmflags=all=-trimpath=${PWD} -ldflags=-extldflags=-zrelro -ldflags=-extldflags=-$LDFLAGS"
+ export GOFLAGS="-gcflags=all=-trimpath=$PWD -asmflags=all=-trimpath=${PWD} -ldflags=-extldflags=$LDFLAGS"
cd "go/src/github.com/pwr22/$_cmdname" # going through the symlink is necessary to make go get happy
go get ./...
@@ -30,7 +30,7 @@ build() {
cd "$_cmdname-$pkgver"
export GOPATH="$srcdir/go"
- export GOFLAGS="-gcflags=all=-trimpath=$PWD -asmflags=all=-trimpath=${PWD} -ldflags=-extldflags=-zrelro -ldflags=-extldflags=-$LDFLAGS"
+ export GOFLAGS="-gcflags=all=-trimpath=$PWD -asmflags=all=-trimpath=${PWD} -ldflags=-extldflags=$LDFLAGS"
go build -o "$_cmdname"
}