summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaksym Sheremet2019-03-05 21:32:46 +0200
committerMaksym Sheremet2019-03-05 21:32:46 +0200
commitaa31834bfa02d63e6e7e8b8e04bfa078d6ddd472 (patch)
tree9bd6bb5dff3390eeb2edd514f201933fcc34b8bd
parent2a62b856f0c002729aaba0b9f89470ae416eb815 (diff)
downloadaur-aa31834bfa02d63e6e7e8b8e04bfa078d6ddd472.tar.gz
Fixed screenshot issue for WM's launched with xinit.
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD7
-rw-r--r--xdg_session_type.patch12
4 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2052e9b53a78..9bd3ec2b3f41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = upwork
pkgdesc = Desktop App 64-bit Standard version
pkgver = 5.1.0.647
- pkgrel = 1
+ pkgrel = 2
url = https://www.upwork.com/downloads?source=Footer
install = upwork.install
arch = x86_64
@@ -15,7 +15,9 @@ pkgbase = upwork
depends = nss
conflicts = upwork-alpha
source = LICENSE
+ source = xdg_session_type.patch
md5sums = bb535c74d4673cee6437b04d33b32138
+ md5sums = c99eddfeb02a2dc5272b82b276b88c8a
source_x86_64 = https://updates-desktopapp.upwork.com/binaries/v5_1_0_647_g0nxmj7uab8q069t/upwork_5.1.0.647_amd64.deb
md5sums_x86_64 = 5ff7848a1c95f60fd4ba31b0c3f8de86
diff --git a/.gitignore b/.gitignore
index 497aa726cbbe..3da0280f2e71 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,3 +4,4 @@
!*.install
!.gitignore
!LICENSE
+!xdg_session_type.patch
diff --git a/PKGBUILD b/PKGBUILD
index 5ce9fc236896..2215c990b7e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=upwork
pkgver=5.1.0.647
_rawver=${pkgver//./_}
_hashver="g0nxmj7uab8q069t"
-pkgrel=1
+pkgrel=2
pkgdesc="Desktop App 64-bit Standard version"
arch=('x86_64')
url="https://www.upwork.com/downloads?source=Footer"
@@ -13,8 +13,8 @@ license=('custom')
conflicts=('upwork-alpha')
depends=('alsa-lib' 'gconf' 'gdk-pixbuf2' 'gtk2' 'libxss' 'libxtst' 'nss')
install=upwork.install
-source=("LICENSE")
-md5sums=('bb535c74d4673cee6437b04d33b32138')
+source=("LICENSE" "xdg_session_type.patch")
+md5sums=('bb535c74d4673cee6437b04d33b32138' 'c99eddfeb02a2dc5272b82b276b88c8a')
md5sums_x86_64=('5ff7848a1c95f60fd4ba31b0c3f8de86')
# how to get links Prod, Beta, Alpha: grep "_getVersionToDownload" ~/.Upwork/Upwork/Logs/* | tail -n 1
source_x86_64=(https://updates-desktopapp.upwork.com/binaries/v${_rawver}_${_hashver}/upwork_${pkgver}_amd64.deb)
@@ -22,6 +22,7 @@ source_x86_64=(https://updates-desktopapp.upwork.com/binaries/v${_rawver}_${_has
prepare() {
cd "${srcdir}"
tar -xJf "${srcdir}/data.tar.xz"
+ patch -p1 --input="../xdg_session_type.patch"
}
package() {
diff --git a/xdg_session_type.patch b/xdg_session_type.patch
new file mode 100644
index 000000000000..f1d8e5a3aa9c
--- /dev/null
+++ b/xdg_session_type.patch
@@ -0,0 +1,12 @@
+--- src/usr/bin/upwork 2018-11-08 21:07:12.000000000 +0200
++++ upwork.patched 2019-03-05 20:42:12.082295838 +0200
+@@ -6,5 +6,9 @@
+ export XDG_CURRENT_DESKTOP=Unity
+ fi
+
++if [ $XDG_SESSION_TYPE == 'tty' ]; then
++ export XDG_SESSION_TYPE=x11
++fi
++
+ cd /usr/share/upwork
+ exec ./upwork "$@"