summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAuguste Pop2015-06-11 16:21:00 +0800
committerAuguste Pop2015-06-11 16:21:00 +0800
commitaa43d8e5a572a2f0dda7304475daa36ee64aac1c (patch)
tree51ee1e63df68aafd4356fce8e1ea7fd5f0f24f43
downloadaur-aa43d8e5a572a2f0dda7304475daa36ee64aac1c.tar.gz
migrate from aur
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
-rw-r--r--hodoku.desktop9
-rw-r--r--hodoku.pngbin0 -> 22456 bytes
-rw-r--r--hodoku.sh3
5 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e51b124649b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = hodoku
+ pkgdesc = Sudoku generator/solver/analyzer
+ pkgver = 2.2.0
+ pkgrel = 1
+ url = http://hodoku.sourceforge.net/en/index.php
+ arch = any
+ license = GPL3
+ depends = java-runtime
+ noextract = hodoku.jar
+ source = http://downloads.sourceforge.net/project/hodoku/hodoku/hodoku_2.2.0/hodoku.jar
+ source = hodoku.sh
+ source = hodoku.png
+ source = hodoku.desktop
+ md5sums = fa8d728b76f524b97762f4fe0b82152a
+ md5sums = 883f82c99d42ad5113e84c6a501a66b5
+ md5sums = 01d77a4d9f4fd1fb36690ee8a3bae6c4
+ md5sums = 557ca158902fddf06cbda7c7c9480c08
+
+pkgname = hodoku
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57a6e7a7eb17
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Auguste Pop < auguste [at] gmail [dot] com >
+# Contributor: SanskritFritz (gmail)
+# Contributor: SiD/sidious <miste78 web de>
+
+pkgname=hodoku
+pkgver=2.2.0
+pkgrel=1
+pkgdesc="Sudoku generator/solver/analyzer"
+url="http://hodoku.sourceforge.net/en/index.php"
+license=('GPL3')
+arch=('any')
+depends=('java-runtime')
+source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname/${pkgname}_${pkgver}/$pkgname.jar
+ $pkgname.sh
+ $pkgname.png
+ $pkgname.desktop)
+noextract=($pkgname.jar)
+md5sums=('fa8d728b76f524b97762f4fe0b82152a'
+ '883f82c99d42ad5113e84c6a501a66b5'
+ '01d77a4d9f4fd1fb36690ee8a3bae6c4'
+ '557ca158902fddf06cbda7c7c9480c08')
+
+package()
+{
+ cd "$srcdir"
+ install -m 644 -D $pkgname.jar \
+ "$pkgdir/usr/share/java/$pkgname/$pkgname.jar"
+ install -m 755 -D $pkgname.sh \
+ "$pkgdir/usr/bin/$pkgname"
+ install -m 644 -D $pkgname.png \
+ "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -m 644 -D $pkgname.desktop \
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
+}
diff --git a/hodoku.desktop b/hodoku.desktop
new file mode 100644
index 000000000000..1c21a8305058
--- /dev/null
+++ b/hodoku.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=HoDoKu
+Comment=A sudoku helper written in Java
+Exec=hodoku
+Icon=hodoku
+Terminal=false
+Categories=Game;LogicGame;Java
diff --git a/hodoku.png b/hodoku.png
new file mode 100644
index 000000000000..2ee14de0331f
--- /dev/null
+++ b/hodoku.png
Binary files differ
diff --git a/hodoku.sh b/hodoku.sh
new file mode 100644
index 000000000000..20f3e6eba7ca
--- /dev/null
+++ b/hodoku.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+java -Xmx256m -jar /usr/share/java/hodoku/hodoku.jar