summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2015-06-17 08:55:29 -0700
committerAnatol Pomozov2015-06-17 08:55:29 -0700
commitaa657e89769c1d9520c1f5fa1255e3997884c8ed (patch)
tree2354464bba9243e0911dfb680f5bef74bb33859e
downloadaur-aa657e89769c1d9520c1f5fa1255e3997884c8ed.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
-rw-r--r--use_picotest_pkg.patch9
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bcf10c47f671
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = yoml-git
+ pkgdesc = a DOM-like interface to YAML
+ pkgver = r12.8ce39f7
+ pkgrel = 1
+ url = https://github.com/h2o/yoml
+ arch = any
+ license = unknown
+ checkdepends = picotest-git
+ makedepends = git
+ depends = libyaml
+ source = git+https://github.com/h2o/yoml
+ source = use_picotest_pkg.patch
+ sha256sums = SKIP
+ sha256sums = 9906eca6e57e5dadb32af1c83b46726801ef487d98ddb30ec314fd4c958dd569
+
+pkgname = yoml-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4287b12bcdc9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
+
+pkgname=yoml-git
+pkgver=r12.8ce39f7
+pkgrel=1
+pkgdesc='a DOM-like interface to YAML'
+arch=(any)
+url='https://github.com/h2o/yoml'
+license=(unknown)
+depends=(libyaml)
+makedepends=(git)
+checkdepends=(picotest-git)
+source=(git+https://github.com/h2o/yoml
+ use_picotest_pkg.patch)
+sha256sums=('SKIP'
+ '9906eca6e57e5dadb32af1c83b46726801ef487d98ddb30ec314fd4c958dd569')
+
+prepare() {
+ cd yoml
+ patch -p1 < ../use_picotest_pkg.patch
+}
+
+pkgver() {
+ cd yoml
+ echo r$(git rev-list --count master).$(git rev-parse --short master)
+}
+
+check() {
+ cd yoml
+# fails with recent picotest
+ make test
+}
+
+package() {
+ cd yoml
+ install -d "$pkgdir"/usr/include
+ install -m644 yoml.h yoml-parser.h "$pkgdir"/usr/include
+}
diff --git a/use_picotest_pkg.patch b/use_picotest_pkg.patch
new file mode 100644
index 000000000000..00d4ab61af34
--- /dev/null
+++ b/use_picotest_pkg.patch
@@ -0,0 +1,9 @@
+diff --git a/Makefile b/Makefile
+index 6f48590..4be2030 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,3 +1,3 @@
+ test:
+- $(CC) -Wall -g -I deps/picotest deps/picotest/picotest.c test-yoml.c -lyaml -o test-yoml
++ $(CC) -Wall -g test-yoml.c -lyaml -lpicotest -o test-yoml
+ ./test-yoml