summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2024-02-25 18:20:02 +0100
committerMartchus2024-02-25 18:20:02 +0100
commitaa748da790ebf9e1fd4d7f23c3561afd4ce4796d (patch)
tree73c57aad4ff9410903ca37beb8f65c6df22efe09
parent02b5f6c747fc49bc0136a2cd9efcc3e2f9497639 (diff)
downloadaur-aa748da790ebf9e1fd4d7f23c3561afd4ce4796d.tar.gz
Force Android Qt 6 packages to use Java 17
This may help to prevent https://bugreports.qt.io/browse/QTBUG-119223.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--PKGBUILD.sh.ep2
3 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28ac5d256305..7dbe92d0cfda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,7 +14,7 @@ pkgbase = android-aarch64-qt6-tools
makedepends = qt6-declarative
makedepends = qt6-tools
makedepends = ninja
- makedepends = java-environment-openjdk>=11
+ makedepends = java-environment-openjdk=17
depends = android-aarch64-qt6-base
options = !strip
options = !buildflags
diff --git a/PKGBUILD b/PKGBUILD
index 8cd88158bb83..449381b65f49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
pkgdesc='A cross-platform application and UI framework (tools, android)'
depends=('android-aarch64-qt6-base')
-makedepends=('android-cmake' 'android-aarch64-qt6-declarative' 'qt6-declarative' 'qt6-tools' 'ninja' 'java-environment-openjdk>=11')
+makedepends=('android-cmake' 'android-aarch64-qt6-declarative' 'qt6-declarative' 'qt6-tools' 'ninja' 'java-environment-openjdk=17')
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(android-${_android_arch}-qt6)
_pkgfqn="qttools-everywhere-src-${_qtver}"
@@ -33,6 +33,7 @@ prepare () {
}
build() {
+ export PATH=/usr/lib/jvm/java-17-openjdk/bin:$PATH
source android-env ${_android_arch}
android-${_android_arch}-cmake -G Ninja -B build-$_android_arch -S $_pkgfqn \
-DCMAKE_FIND_ROOT_PATH="${ANDROID_PREFIX}" \
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 35f84876165d..c16808096ccb 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -8,4 +8,4 @@ url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
pkgdesc='A cross-platform application and UI framework (tools, android)'
depends=(<%== qt6deps qw(base) %>)
-makedepends=('android-cmake<%== $static_suffix %>' <%== qt6deps qw(declarative) %> 'qt6-declarative' 'qt6-tools' 'ninja' 'java-environment-openjdk>=11')
+makedepends=('android-cmake<%== $static_suffix %>' <%== qt6deps qw(declarative) %> 'qt6-declarative' 'qt6-tools' 'ninja' 'java-environment-openjdk=17')