summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Wolsieffer2016-12-11 13:41:27 -0500
committerBen Wolsieffer2016-12-11 13:41:27 -0500
commitaa81eb4ea2a40ad968c943c60ed626f7dc437df9 (patch)
tree66cff93b8d039360019fbc16b2f48bb81a8c5411
downloadaur-aa81eb4ea2a40ad968c943c60ed626f7dc437df9.tar.gz
Create package based off python2-sphinx-autobuild
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a1dfbf77259
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Sun Dec 11 18:41:19 UTC 2016
+pkgbase = python-sphinx-autobuild
+ pkgdesc = Watch a Sphinx directory and rebuild the documentation when a change is detected. Also includes a livereload enabled web server.
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://github.com/GaretJax/sphinx-autobuild
+ arch = any
+ license = MIT
+ depends = python-sphinx
+ depends = python-watchdog>=0.7.1
+ depends = python-argh>=0.24.1
+ depends = python-pathtools>=0.1.2
+ depends = python-yaml>=3.10
+ depends = python-tornado>=3.2
+ depends = python-port-for=0.3.1
+ depends = python-livereload>=2.3.0
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/s/sphinx-autobuild/sphinx-autobuild-0.6.0.tar.gz
+ sha256sums = 2f9262d7a35f80a18c3bcb03b2bf5a83f0a5e88b75ad922b3b1cee512c7e5cd2
+
+pkgname = python-sphinx-autobuild
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7540c13366ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Ben Wolsieffer <benwolsieffer@gmail.com>
+pkgname=python-sphinx-autobuild
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="Watch a Sphinx directory and rebuild the documentation when a change is detected. Also includes a livereload enabled web server."
+arch=('any')
+url="https://github.com/GaretJax/sphinx-autobuild"
+license=('MIT')
+groups=()
+depends=(
+ 'python-sphinx'
+ 'python-watchdog>=0.7.1'
+ 'python-argh>=0.24.1'
+ 'python-pathtools>=0.1.2'
+ 'python-yaml>=3.10'
+ 'python-tornado>=3.2'
+ 'python-port-for=0.3.1'
+ 'python-livereload>=2.3.0'
+)
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=(
+ https://pypi.python.org/packages/source/s/sphinx-autobuild/sphinx-autobuild-$pkgver.tar.gz
+)
+sha256sums=('2f9262d7a35f80a18c3bcb03b2bf5a83f0a5e88b75ad922b3b1cee512c7e5cd2')
+
+package() {
+ cd "$srcdir/sphinx-autobuild-$pkgver"
+
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: