summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2020-11-24 18:35:51 -0500
committerSlashbunny2020-11-24 18:35:51 -0500
commitaa86bb4b33ce56eb642270c7dba46801c07dbc79 (patch)
tree10a216571ed283b52e7a9598e922c70d74e5df9e
parent3e52ade1d1a59df7f56e5019de6472349952419d (diff)
downloadaur-aa86bb4b33ce56eb642270c7dba46801c07dbc79.tar.gz
Update to latest
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 17 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff870c3427c2..2878a0478b48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ezquake
pkgdesc = One of the most Popular QuakeWorld clients for Linux/BSD/OSX/Win32. You need the retail pak files to play.
- pkgver = 3.2
- pkgrel = 3
+ pkgver = 3.2.2
+ pkgrel = 1
url = http://ezquake.sourceforge.net/
install = ezquake.install
arch = x86_64
@@ -20,19 +20,17 @@ pkgbase = ezquake
provides = fuhquake
conflicts = ezquake-git
conflicts = fuhquake
- noextract = ezquake-ubuntu-full-3.2.tar.gz
- source = https://github.com/ezQuake/ezquake-source/archive/3.2.tar.gz
- source = https://github.com/ezQuake/ezquake-source/releases/download/3.2/ezquake-ubuntu-full-3.2.tar.gz
+ noextract = ezquake-ubuntu-full-3.2.2.tar.gz
+ source = https://github.com/ezQuake/ezquake-source/archive/3.2.2.tar.gz
+ source = https://github.com/ezQuake/ezquake-source/releases/download/3.2.2/ezquake-ubuntu-3.2.2-full.tar.gz
source = ezquake.launcher
source = ezquake.desktop
source = ezquake.ico
- source = gcc10.patch
- sha256sums = 801151d540706106cbd26da7266aa5e330842b8cccbc5acd4bc8d5a73db3515d
- sha256sums = 6977480a374e531341dec82ccabf3f1443c674959f0e959b7a4c9a63cc2e06c5
+ sha256sums = 2ca2c455bcdd4cd7c3ac95fa87a8a4e3463aa86a5dbe0fd18576f8d9790425fa
+ sha256sums = ef594c51b210fb0e534fbd1c46b63a011f473a8f942cda7802289568dd41fefe
sha256sums = aa59da4a296a43af8ea8c5670cef5980a15407124b3e53f3cf805ceb6126e6ed
sha256sums = e92b9cdeac5eadced50a6167eb53b1343b0772d3bf8afa310eb281b88bf7e677
sha256sums = 2a6a5484ddb4cfaf8518b51df39ffd1fa8ce768402eab6401415bececb8e8ab2
- sha256sums = 6d5dd357210c437ba77ce0ee4fbc0ed6e242ec17ead80b4d76c4a59fcb4b683a
pkgname = ezquake
diff --git a/.gitignore b/.gitignore
index 83e74ab09fce..4b6d7f00e734 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,5 +3,5 @@ pkg/
*.pkg.tar.xz
*.pkg.tar
*.src.tar.gz
-ezquake-*-full-*.tar.gz
-3.2.tar.gz
+ezquake-*full*.tar.gz
+3.2.*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 306a9235b8eb..ddbb51886e27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Slash <demodevil5[at]yahoo[dot]com>
pkgname=ezquake
-pkgver=3.2
-pkgrel=3
+pkgver=3.2.2
+pkgrel=1
pkgdesc="One of the most Popular QuakeWorld clients for Linux/BSD/OSX/Win32. You need the retail pak files to play."
url="http://ezquake.sourceforge.net/"
license=('GPL')
@@ -13,22 +13,14 @@ provides=('quake' 'fuhquake')
arch=('x86_64')
install=ezquake.install
source=("https://github.com/ezQuake/ezquake-source/archive/${pkgver}.tar.gz"
-"https://github.com/ezQuake/ezquake-source/releases/download/${pkgver}/ezquake-ubuntu-full-${pkgver}.tar.gz"
-'ezquake.launcher' 'ezquake.desktop' 'ezquake.ico' 'gcc10.patch')
+"https://github.com/ezQuake/ezquake-source/releases/download/${pkgver}/ezquake-ubuntu-${pkgver}-full.tar.gz"
+'ezquake.launcher' 'ezquake.desktop' 'ezquake.ico')
noextract=("ezquake-ubuntu-full-${pkgver}.tar.gz")
-sha256sums=('801151d540706106cbd26da7266aa5e330842b8cccbc5acd4bc8d5a73db3515d'
- '6977480a374e531341dec82ccabf3f1443c674959f0e959b7a4c9a63cc2e06c5'
+sha256sums=('2ca2c455bcdd4cd7c3ac95fa87a8a4e3463aa86a5dbe0fd18576f8d9790425fa'
+ 'ef594c51b210fb0e534fbd1c46b63a011f473a8f942cda7802289568dd41fefe'
'aa59da4a296a43af8ea8c5670cef5980a15407124b3e53f3cf805ceb6126e6ed'
'e92b9cdeac5eadced50a6167eb53b1343b0772d3bf8afa310eb281b88bf7e677'
- '2a6a5484ddb4cfaf8518b51df39ffd1fa8ce768402eab6401415bececb8e8ab2'
- '6d5dd357210c437ba77ce0ee4fbc0ed6e242ec17ead80b4d76c4a59fcb4b683a')
-
-prepare() {
- cd "${srcdir}/ezquake-source-${pkgver}/"
-
- # Patch to fix build on GCC10
- patch -p1 < "${srcdir}/gcc10.patch"
-}
+ '2a6a5484ddb4cfaf8518b51df39ffd1fa8ce768402eab6401415bececb8e8ab2')
build() {
cd "${srcdir}/ezquake-source-${pkgver}/"
@@ -44,7 +36,7 @@ package() {
install -d "${pkgdir}/opt/quake"
# Unpack ezQuake assets package (base)
- bsdtar -x -o -C "${pkgdir}/opt/quake" -f "${srcdir}/ezquake-ubuntu-full-${pkgver}.tar.gz"
+ bsdtar -x -o -C "${pkgdir}/opt/quake" -f "${srcdir}/ezquake-ubuntu-${pkgver}-full.tar.gz"
# Clean up permissions in assets package
find "${pkgdir}/opt/quake" -type d -exec chmod 0755 "{}" \;