summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-01-03 21:28:29 -0500
committerVincent Grande2021-01-03 21:28:29 -0500
commitaa9b2caafc6f59dd1fb80e27b80faed4426481aa (patch)
tree0cf75530e7b6f616fb0181dc8ced3a65060900f4
downloadaur-aa9b2caafc6f59dd1fb80e27b80faed4426481aa.tar.gz
initial upload
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72696242c382
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = glu-git
+ pkgdesc = Mesa OpenGL Utility library
+ pkgver = 9.0.1
+ pkgrel = 1
+ url = https://cgit.freedesktop.org/mesa/glu/
+ arch = x86_64
+ license = LGPL
+ depends = libgl
+ provides = glu
+ conflicts = glu
+ source = git+https://gitlab.freedesktop.org/mesa/glu.git
+ sha512sums = SKIP
+
+pkgname = glu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d716b3f419e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Laurent Carlier <lordheavym@gmail.com>
+
+pkgname=glu-git
+pkgver=9.0.1
+pkgrel=1
+pkgdesc="Mesa OpenGL Utility library"
+arch=('x86_64')
+url="https://cgit.freedesktop.org/mesa/glu/"
+license=('LGPL')
+depends=('libgl')
+provides=(glu)
+conflicts=(glu)
+source=("git+https://gitlab.freedesktop.org/mesa/glu.git")
+sha512sums=('SKIP')
+#validpgpkeys=('3BB639E56F861FA2E86505690FDD682D974CA72A') # "Matt Turner <mattst88@gmail.com>"
+
+build() {
+ cd "$srcdir/glu"
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+#check() {
+# cd "$srcdir/glu"
+# make -k check
+#}
+
+package() {
+ cd "$srcdir/glu"
+ make DESTDIR="$pkgdir/" install
+}