summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-07-06 18:01:20 +0000
committerBioArchLinuxBot2023-07-06 18:01:20 +0000
commitaaabce8428d8a002336f7d319f1472565226d5d3 (patch)
tree5fb13e9581d89bca6307a477599814cb8dae4f43
parent3bc519d8bb0b723294a4f63f5f0d5032daea0bf0 (diff)
downloadaur-aaabce8428d8a002336f7d319f1472565226d5d3.tar.gz
[lilac] updated to 1.8.12-3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD55
2 files changed, 32 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc2768615e68..0e028029427c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = r-zoo
pkgdesc = S3 Infrastructure for Regular and Irregular Time Series (Z's Ordered Observations)
pkgver = 1.8.12
- pkgrel = 1
+ pkgrel = 3
url = https://cran.r-project.org/package=zoo
- arch = i686
arch = x86_64
license = GPL
depends = r
optdepends = r-aer
- optdepends = r-coda
optdepends = r-chron
+ optdepends = r-coda
optdepends = r-ggplot2
optdepends = r-mondate
optdepends = r-scales
@@ -21,6 +20,7 @@ pkgbase = r-zoo
optdepends = r-tseries
optdepends = r-xts
source = https://cran.r-project.org/src/contrib/zoo_1.8-12.tar.gz
+ md5sums = 9bf826a22610f5a3f8ebd063404e7183
sha256sums = e6c3862668f9e3422bced3b6fba485c76a1e91b48f5d6153822d6a61863b2fb8
pkgname = r-zoo
diff --git a/PKGBUILD b/PKGBUILD
index 594763aaed86..c7e5ca6dab9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,47 @@
# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Ward Segers <w@rdsegers.be>
# Contributor: Alex Branham <alex.branham@gmail.com>
# Contributor: wagnerflo <florian@wagner-flo.net>
-_cranname=zoo
-_cranver=1.8-12
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=1
+_pkgname=zoo
+_pkgver=1.8-12
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=3
pkgdesc="S3 Infrastructure for Regular and Irregular Time Series (Z's Ordered Observations)"
-arch=(i686 x86_64)
-url="https://cran.r-project.org/package=${_cranname}"
+arch=(x86_64)
+url="https://cran.r-project.org/package=${_pkgname}"
license=(GPL)
-depends=(r)
+depends=(
+ r
+)
optdepends=(
- r-aer
- r-coda
- r-chron
- r-ggplot2
- r-mondate
- r-scales
- r-stinepack
- r-strucchange
- r-timedate
- r-timeseries
- r-tis
- r-tseries
- r-xts
+ r-aer
+ r-chron
+ r-coda
+ r-ggplot2
+ r-mondate
+ r-scales
+ r-stinepack
+ r-strucchange
+ r-timedate
+ r-timeseries
+ r-tis
+ r-tseries
+ r-xts
)
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('9bf826a22610f5a3f8ebd063404e7183')
sha256sums=('e6c3862668f9e3422bced3b6fba485c76a1e91b48f5d6153822d6a61863b2fb8')
build() {
mkdir -p build
- R CMD INSTALL "${_cranname}" -l "${srcdir}/build"
+ R CMD INSTALL "$_pkgname" -l build
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
-
- cp -a --no-preserve=ownership "build/${_cranname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}