summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2024-03-28 14:41:55 +0100
committerNicola Murino2024-03-28 14:41:55 +0100
commitaab1c26fd940db39a214136c3efb076e3110d319 (patch)
tree3d54db95a63d4aea5aa4da606c819a870a8c1f14
parenteade704b8c89e21606cdbdc8cc604f71aece93f9 (diff)
downloadaur-aab1c26fd940db39a214136c3efb076e3110d319.tar.gz
improve fix for DirectXMath detection
-rw-r--r--.SRCINFO4
-rw-r--r--0001-fix-DirectXMath-detection.patch25
-rw-r--r--0001-fix-DirectXMath.h-include-path.patch132
-rw-r--r--PKGBUILD6
4 files changed, 30 insertions, 137 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b18793f6a8cb..12c19b3546a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -43,8 +43,8 @@ pkgbase = mingw-w64-gst-plugins-bad
options = !buildflags
options = staticlibs
source = http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-1.24.1.tar.xz
- source = 0001-fix-DirectXMath.h-include-path.patch
+ source = 0001-fix-DirectXMath-detection.patch
sha256sums = f1a183966ea9136a00f159ee42db4d1d106abef022d1b49e63fba2fcbe50c8f8
- sha256sums = 51f80198efeedd14424a2f2ea3d3395c0fec6c8c853017fd4fc459abd669f1ea
+ sha256sums = 3eee4a3e2751d6fc24852b6cf27d42e660858d02ec31620fb1f3a2ecebb4923a
pkgname = mingw-w64-gst-plugins-bad
diff --git a/0001-fix-DirectXMath-detection.patch b/0001-fix-DirectXMath-detection.patch
new file mode 100644
index 000000000000..65347fdf154b
--- /dev/null
+++ b/0001-fix-DirectXMath-detection.patch
@@ -0,0 +1,25 @@
+From 09cedd4384bb2e9446272c188df1b5cad4d28378 Mon Sep 17 00:00:00 2001
+From: Nicola Murino <nicola.murino@gmail.com>
+Date: Thu, 28 Mar 2024 14:21:57 +0100
+Subject: [PATCH] fix DirectXMath detection
+
+---
+ gst-libs/gst/d3d11/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gst-libs/gst/d3d11/meson.build b/gst-libs/gst/d3d11/meson.build
+index 5abb136..e949be2 100644
+--- a/gst-libs/gst/d3d11/meson.build
++++ b/gst-libs/gst/d3d11/meson.build
+@@ -196,7 +196,7 @@ have_dx_math = cxx.compiles('''
+ name: 'DirectXMath support in Windows SDK')
+
+ if not have_dx_math
+- directxmath_dep = dependency('directxmath',
++ directxmath_dep = dependency('DirectXMath',
+ allow_fallback: true,
+ required: get_option('d3d11-math'))
+ extra_deps += [directxmath_dep]
+--
+2.44.0
+
diff --git a/0001-fix-DirectXMath.h-include-path.patch b/0001-fix-DirectXMath.h-include-path.patch
deleted file mode 100644
index f05dfdc08f06..000000000000
--- a/0001-fix-DirectXMath.h-include-path.patch
+++ /dev/null
@@ -1,132 +0,0 @@
-From 1408244202834f7cd7fd48fd271249555d14b17e Mon Sep 17 00:00:00 2001
-From: Nicola Murino <nicola.murino@gmail.com>
-Date: Thu, 28 Mar 2024 13:24:10 +0100
-Subject: [PATCH] fix DirectXMath.h include path
-
----
- gst-libs/gst/d3d11/gstd3d11converter.cpp | 2 +-
- gst-libs/gst/d3d11/meson.build | 4 ++--
- sys/d3d11/gstd3d11dxgicapture.cpp | 2 +-
- sys/d3d11/gstd3d11pluginutils.cpp | 2 +-
- sys/d3d12/gstd3d12converter.cpp | 2 +-
- sys/d3d12/gstd3d12dxgicapture.cpp | 2 +-
- sys/d3d12/gstd3d12pluginutils.cpp | 2 +-
- sys/d3d12/meson.build | 2 +-
- 8 files changed, 9 insertions(+), 9 deletions(-)
-
-diff --git a/gst-libs/gst/d3d11/gstd3d11converter.cpp b/gst-libs/gst/d3d11/gstd3d11converter.cpp
-index 813a0ff..65d1b34 100644
---- a/gst-libs/gst/d3d11/gstd3d11converter.cpp
-+++ b/gst-libs/gst/d3d11/gstd3d11converter.cpp
-@@ -43,7 +43,7 @@
- #ifndef HAVE_DIRECTX_MATH_SIMD
- #define _XM_NO_INTRINSICS_
- #endif
--#include <DirectXMath.h>
-+#include <directxmath/DirectXMath.h>
-
- /**
- * SECTION:gstd3d11converter
-diff --git a/gst-libs/gst/d3d11/meson.build b/gst-libs/gst/d3d11/meson.build
-index 5abb136..2f129c7 100644
---- a/gst-libs/gst/d3d11/meson.build
-+++ b/gst-libs/gst/d3d11/meson.build
-@@ -183,7 +183,7 @@ endif
-
- have_dx_math = cxx.compiles('''
- #include <windows.h>
-- #include <DirectXMath.h>
-+ #include <directxmath/DirectXMath.h>
- using namespace DirectX;
- int main(int argc, char ** argv) {
- XMMATRIX matrix;
-@@ -207,7 +207,7 @@ endif
- if host_machine.cpu_family() != 'x86'
- have_dx_math_simd = cxx.compiles('''
- #include <windows.h>
-- #include <DirectXMath.h>
-+ #include <directxmath/DirectXMath.h>
- using namespace DirectX;
- int main(int argc, char ** argv) {
- XMVerifyCPUSupport ();
-diff --git a/sys/d3d11/gstd3d11dxgicapture.cpp b/sys/d3d11/gstd3d11dxgicapture.cpp
-index aeb8d38..0403003 100644
---- a/sys/d3d11/gstd3d11dxgicapture.cpp
-+++ b/sys/d3d11/gstd3d11dxgicapture.cpp
-@@ -54,7 +54,7 @@
- #include <wrl.h>
-
- #define _XM_NO_INTRINSICS_
--#include <DirectXMath.h>
-+#include <directxmath/DirectXMath.h>
-
- GST_DEBUG_CATEGORY_EXTERN (gst_d3d11_screen_capture_debug);
- #define GST_CAT_DEFAULT gst_d3d11_screen_capture_debug
-diff --git a/sys/d3d11/gstd3d11pluginutils.cpp b/sys/d3d11/gstd3d11pluginutils.cpp
-index db64725..7770b93 100644
---- a/sys/d3d11/gstd3d11pluginutils.cpp
-+++ b/sys/d3d11/gstd3d11pluginutils.cpp
-@@ -32,7 +32,7 @@
-
- /* Disable platform-specific intrinsics */
- #define _XM_NO_INTRINSICS_
--#include <DirectXMath.h>
-+#include <directxmath/DirectXMath.h>
-
- GST_DEBUG_CATEGORY_EXTERN (gst_d3d11_plugin_utils_debug);
- #define GST_CAT_DEFAULT gst_d3d11_plugin_utils_debug
-diff --git a/sys/d3d12/gstd3d12converter.cpp b/sys/d3d12/gstd3d12converter.cpp
-index f89da10..0346599 100644
---- a/sys/d3d12/gstd3d12converter.cpp
-+++ b/sys/d3d12/gstd3d12converter.cpp
-@@ -35,7 +35,7 @@
- #ifndef HAVE_DIRECTX_MATH_SIMD
- #define _XM_NO_INTRINSICS_
- #endif
--#include <DirectXMath.h>
-+#include <directxmath/DirectXMath.h>
-
- GST_DEBUG_CATEGORY (gst_d3d12_converter_debug);
- #define GST_CAT_DEFAULT gst_d3d12_converter_debug
-diff --git a/sys/d3d12/gstd3d12dxgicapture.cpp b/sys/d3d12/gstd3d12dxgicapture.cpp
-index 5f18305..b5608df 100644
---- a/sys/d3d12/gstd3d12dxgicapture.cpp
-+++ b/sys/d3d12/gstd3d12dxgicapture.cpp
-@@ -59,7 +59,7 @@
- #include "VSMain_coord.h"
-
- #define _XM_NO_INTRINSICS_
--#include <DirectXMath.h>
-+#include <directxmath/DirectXMath.h>
-
- GST_DEBUG_CATEGORY_EXTERN (gst_d3d12_screen_capture_debug);
- #define GST_CAT_DEFAULT gst_d3d12_screen_capture_debug
-diff --git a/sys/d3d12/gstd3d12pluginutils.cpp b/sys/d3d12/gstd3d12pluginutils.cpp
-index 41987af..3765546 100644
---- a/sys/d3d12/gstd3d12pluginutils.cpp
-+++ b/sys/d3d12/gstd3d12pluginutils.cpp
-@@ -24,7 +24,7 @@
- #include "gstd3d12pluginutils.h"
-
- #define _XM_NO_INTRINSICS_
--#include <DirectXMath.h>
-+#include <directxmath/DirectXMath.h>
-
- /* *INDENT-OFF* */
- using namespace DirectX;
-diff --git a/sys/d3d12/meson.build b/sys/d3d12/meson.build
-index 00db928..383a232 100644
---- a/sys/d3d12/meson.build
-+++ b/sys/d3d12/meson.build
-@@ -83,7 +83,7 @@ d3d12_headers = [
- 'd3d11.h',
- 'd3d11on12.h',
- 'd2d1.h',
-- 'DirectXMath.h',
-+ 'directxmath/DirectXMath.h',
- ]
-
- have_d3d12_headers = true
---
-2.44.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 9fc0e88ca7a6..4676c8869905 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,15 +27,15 @@ optdepends=(
options=('!strip' '!buildflags' 'staticlibs')
source=(${url}src/gst-plugins-bad/gst-plugins-bad-${pkgver}.tar.xz
- 0001-fix-DirectXMath.h-include-path.patch)
+ 0001-fix-DirectXMath-detection.patch)
sha256sums=('f1a183966ea9136a00f159ee42db4d1d106abef022d1b49e63fba2fcbe50c8f8'
- '51f80198efeedd14424a2f2ea3d3395c0fec6c8c853017fd4fc459abd669f1ea')
+ '3eee4a3e2751d6fc24852b6cf27d42e660858d02ec31620fb1f3a2ecebb4923a')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "${srcdir}/gst-plugins-bad-${pkgver}"
- patch -Np1 -i "${srcdir}/0001-fix-DirectXMath.h-include-path.patch"
+ patch -Np1 -i "${srcdir}/0001-fix-DirectXMath-detection.patch"
}