summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-10-19 22:07:35 +0200
committerGustavo Alvarez2016-10-19 22:07:35 +0200
commitaaded8c1afb17bd308190ab6de0cb32c621e6123 (patch)
tree710d623be7ac7a93cc78d7b796d5344719bc3574
parent93c778d86ce87e7560c9568fdb9aca2450d599fd (diff)
downloadaur-aaded8c1afb17bd308190ab6de0cb32c621e6123.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00bea84acb27..c72765120dbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Wed Oct 19 20:07:29 UTC 2016
pkgbase = vapoursynth-plugin-mvsfunc-git
pkgdesc = Plugin for Vapoursynth: mvsfunc (GIT version)
- pkgver = v5.r29.1e20b50
+ pkgver = v9.r48.413e23f
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=172564
arch = i686
@@ -12,7 +14,7 @@ pkgbase = vapoursynth-plugin-mvsfunc-git
provides = vapoursynth-plugin-mvsfunc
conflicts = vapoursynth-plugin-mvsfunc
source = mvsfunc::git+https://github.com/HomeOfVapourSynthEvolution/mvsfunc.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-mvsfunc-git
diff --git a/PKGBUILD b/PKGBUILD
index 425a973f6b6f..a6915365d554 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=mvsfunc
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v5.r29.1e20b50
+pkgver=v9.r48.413e23f
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
@@ -15,9 +15,9 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/mvsfunc.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
-_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
pkgver() {
cd "${_plug}"
@@ -27,5 +27,7 @@ pkgver() {
package() {
cd "${_plug}"
- install -Dm644 "${_plug}.py" "${pkgdir}${_sites_packages}/${_plug}.py"
+ install -Dm644 "${_plug}.py" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -m compileall -q -f -d "${_sites_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -OO -m compileall -q -f -d "${_sites_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
}