summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhashworks2020-06-08 23:13:26 +0200
committerhashworks2020-06-08 23:13:26 +0200
commitaafd64b4ba5798e241da8b0da6dd588189402f77 (patch)
tree71b63c3a875f886ca467eef1e243d0ced3d77c4c
parent735d49a38f2988a51a9548933c7d9047015b3cea (diff)
downloadaur-aafd64b4ba5798e241da8b0da6dd588189402f77.tar.gz
Checkout tag in source, verify it
-rw-r--r--.SRCINFO3
-rwxr-xr-xPKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8551f76c1df5..70e5e605ee0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,13 +19,14 @@ pkgbase = filebin
backup = etc/webapps/filebin/contact-info.php
backup = etc/webapps/filebin/database.php
backup = etc/webapps/filebin/memcached.php
- source = git+https://github.com/Bluewind/filebin.git
+ source = git+https://github.com/Bluewind/filebin.git#tag=3.4.4?signed
source = filebin-nginx.conf
source = filebin-php-fpm.conf
source = filebin-file-cron.service
source = filebin-file-cron.timer
source = filebin-user-cron.service
source = filebin-user-cron.timer
+ validpgpkeys = CFA6AF15E5C74149FC1D8C086D1655C14CE1C13E
sha256sums = SKIP
sha256sums = 6ed404a3fbc28c6ab35bf1eba67ddcf46cfd48893237155e38d297a13020180c
sha256sums = 034442098d1608807bec2a03028a7c8bb9ae9d286c378e2f668b4aca3cc9d4e1
diff --git a/PKGBUILD b/PKGBUILD
index 17a89990dace..99d86c2ae19a 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ backup=('etc/webapps/filebin/config-local.php'
)
install=filebin.install
options=('!strip' 'emptydirs')
-source=("git+https://github.com/Bluewind/filebin.git"
+source=("git+https://github.com/Bluewind/filebin.git#tag=${pkgver}?signed"
'filebin-nginx.conf'
'filebin-php-fpm.conf'
'filebin-file-cron.service'
@@ -37,9 +37,10 @@ sha256sums=('SKIP'
'36c82c506a058edc50b882200332c6a540aa68a5749919eb62dc6c633c47deb3'
'd73e4b984ab95954bd18e08237c6aa8bec32ccc5699531727362e2c75ba9c25e')
+validpgpkeys=('CFA6AF15E5C74149FC1D8C086D1655C14CE1C13E') # Florian Pritz <bluewind@archlinux.org>
+
prepare() {
cd "${srcdir}/${pkgname}"
- git checkout "${pkgver}"
git submodule update --init --recursive
}