summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsumt2018-04-29 12:13:16 +0300
committersumt2018-04-29 12:13:16 +0300
commitab00bf91c25c462e412724b9909bc5055ac9c96b (patch)
tree501af102ef5815d2514ac39e1617893fbb2eebd4
downloadaur-ab00bf91c25c462e412724b9909bc5055ac9c96b.tar.gz
init pkg
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51c6e7581a67
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-mini-amf
+ pkgdesc = Minimal AMF encoder and decoder for Python
+ pkgver = 0.9.1
+ pkgrel = 1
+ url = https://github.com/zackw/mini-amf
+ arch = x86_64
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2-six
+ depends = python2-defusedxml
+ provides = python2-mini-amf=0.9.1
+ conflicts = python2-mini-amf
+ source = https://files.pythonhosted.org/packages/source/M/Mini-AMF/Mini-AMF-0.9.1.tar.gz
+ md5sums = fb6dc76e798ee76a2d58408427b2b341
+
+pkgname = python2-mini-amf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ec336a6b3ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: sumt <sumt at sci dot fi>
+
+_name=Mini-AMF
+pkgname=python2-mini-amf
+pkgver=0.9.1
+pkgrel=1
+pkgdesc="Minimal AMF encoder and decoder for Python"
+arch=('x86_64')
+url="https://github.com/zackw/mini-amf"
+license=('MIT')
+depends=('python2-six' 'python2-defusedxml')
+makedepends=('python2-setuptools')
+provides=(python2-mini-amf=$pkgver)
+conflicts=(python2-mini-amf)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('fb6dc76e798ee76a2d58408427b2b341')
+
+package() {
+ cd "$_name-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+