summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarchibald8692023-07-19 11:46:43 +0200
committerarchibald8692023-07-19 11:46:43 +0200
commitab134f55da46559b614c4202170f981d7fcc841d (patch)
tree9d3e53efda1922826c2b153c54d335a3921a51c5
parenta688537ac45316d2036db722183b3d4fcd77d04a (diff)
downloadaur-ab134f55da46559b614c4202170f981d7fcc841d.tar.gz
Prefix clang and llvm source directories, disable LTO, build all at once
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore4
-rw-r--r--Makefile2
-rw-r--r--PKGBUILD24
4 files changed, 19 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61c2b89de71a..05ba7c656600 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cling
pkgdesc = Interactive C++ interpreter, built on the top of LLVM and Clang libraries
pkgver = 0.9
- pkgrel = 4
+ pkgrel = 5
url = https://root.cern.ch/cling
arch = i686
arch = x86_64
@@ -17,8 +17,9 @@ pkgbase = cling
optdepends = python-yaml: support for opt-viewer
provides = cling
conflicts = cling
- source = llvm::git+http://root.cern/git/llvm.git#tag=cling-v0.9
- source = clang::git+http://root.cern/git/clang.git#tag=cling-v0.9
+ options = !lto
+ source = cling-llvm::git+http://root.cern/git/llvm.git#tag=cling-v0.9
+ source = cling-clang::git+http://root.cern/git/clang.git#tag=cling-v0.9
source = cling::git+http://root.cern/git/cling.git#tag=v0.9
sha256sums = SKIP
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
index 251fe19c2d3e..f1d6d0d3bee9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,7 @@
/build
-/clang/
/cling/
-/llvm/
+/cling-clang/
+/cling-llvm/
/pkg/
/src/
*.tar.xz
diff --git a/Makefile b/Makefile
index 89311c2f9c3a..d32dd63c6c3f 100644
--- a/Makefile
+++ b/Makefile
@@ -17,4 +17,4 @@ check: build
namcap *.tar.xz
clean:
- rm -rf build clang cling llvm pkg src *.tar.*
+ rm -rf build cling cling-clang cling-llvm pkg src *.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index 1115dca3ec6f..ee1048c4f123 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=cling
pkgver=0.9
-pkgrel=4
+pkgrel=5
pkgdesc="Interactive C++ interpreter, built on the top of LLVM and Clang libraries"
arch=("i686" "x86_64")
url="https://root.cern.ch/cling"
@@ -18,8 +18,8 @@ optdepends=(
"python-yaml: support for opt-viewer"
)
source=(
- "llvm::git+http://root.cern/git/llvm.git#tag=cling-v$pkgver"
- "clang::git+http://root.cern/git/clang.git#tag=cling-v$pkgver"
+ "cling-llvm::git+http://root.cern/git/llvm.git#tag=cling-v$pkgver"
+ "cling-clang::git+http://root.cern/git/clang.git#tag=cling-v$pkgver"
"cling::git+http://root.cern/git/cling.git#tag=v$pkgver"
)
sha256sums=(
@@ -27,20 +27,21 @@ sha256sums=(
"SKIP"
"SKIP"
)
+options=('!lto')
prepare() {
- if [ ! -h "$srcdir/llvm/tools/clang" ]; then
- ln -s "$srcdir/clang" "$srcdir/llvm/tools/clang"
+ if [ ! -h "$srcdir/cling-llvm/tools/clang" ]; then
+ ln -s "$srcdir/cling-clang" "$srcdir/cling-llvm/tools/clang"
fi
- if [ ! -h "$srcdir/llvm/tools/cling" ]; then
- ln -s "$srcdir/cling" "$srcdir/llvm/tools/cling"
+ if [ ! -h "$srcdir/cling-llvm/tools/cling" ]; then
+ ln -s "$srcdir/cling" "$srcdir/cling-llvm/tools/cling"
fi
# patch missing header file
sed -i '/^#include <vector>$/i #include <limits>' \
- "$srcdir/llvm/utils/benchmark/src/benchmark_register.h"
+ "$srcdir/cling-llvm/utils/benchmark/src/benchmark_register.h"
}
build() {
@@ -60,10 +61,9 @@ build() {
-DLLVM_ENABLE_SPHINX=OFF \
-DLLVM_ENABLE_DOXYGEN=OFF \
-DFFI_INCLUDE_DIR=$(pkg-config --cflags-only-I libffi | cut -c3-) \
- "$srcdir/llvm"
+ "$srcdir/cling-llvm"
- ninja clang
- ninja cling
+ ninja
}
package() {
@@ -74,7 +74,7 @@ package() {
install -d "$pkgdir/usr/bin"
ln -s "/opt/cling/bin/cling" "$pkgdir/usr/bin/cling"
- install -Dm644 "$srcdir/llvm/tools/cling/LICENSE.TXT" \
+ install -Dm644 "$srcdir/cling-llvm/tools/cling/LICENSE.TXT" \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
# include CMake target import file so that other packages are able to use