summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormorganamilo2018-09-30 17:24:05 +0100
committermorganamilo2018-09-30 17:24:05 +0100
commitab29a2f9e51099c29ce1215313e14a0ab81b64fd (patch)
treefbe865d7937b2082506b0aafe9303879beeb6922
downloadaur-ab29a2f9e51099c29ce1215313e14a0ab81b64fd.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7e1fe3d6c6b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = putils-git
+ pkgdesc = Utilities for working with pipes
+ pkgver = r3.1e54e08
+ pkgrel = 1
+ url = https://github.com/Morganamilo/putils
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = go
+ makedepends = asciidoc
+ provides = putils
+ conflicts = putils
+ source = git+https://github.com/Morganamilo/putils
+ md5sums = SKIP
+
+pkgname = putils-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1217f723b464
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Anna <morganamilo@gmail.com>
+_pkgname=putils
+pkgname=putils-git
+pkgver=r3.1e54e08
+pkgrel=1
+pkgdesc="Utilities for working with pipes"
+arch=(x86_64)
+url="https://github.com/Morganamilo/putils"
+license=('GPL3')
+makedepends=(git go asciidoc)
+provides=(putils)
+conflicts=(putils)
+source=("git+https://github.com/Morganamilo/putils")
+md5sums=('SKIP')
+
+build() {
+ cd "$_pkgname"
+ make PREFIX=/usr DESTDIR="$pkgdir" all
+}
+
+package() {
+ cd "$_pkgname"
+ make PREFIX=/usr DESTDIR="$pkgdir" install_all
+}
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+