summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGitlab CI Runner2019-12-02 09:03:04 +0000
committerGitlab CI Runner2019-12-02 09:03:04 +0000
commitab520924d96d36e3f4129a5fd65f439789578e1b (patch)
tree86f612bd7d5c0bb63253a967246e0677059de99f
parentb116566ef1d0360652ae35762cb1eef92f0b0f44 (diff)
downloadaur-ab520924d96d36e3f4129a5fd65f439789578e1b.tar.gz
Updated package to commit
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--rapidcheck.changelog18
3 files changed, 23 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 055ffdb007e8..406e2b8c7bb2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rapidcheck
pkgdesc = QuickCheck clone for C++ with the goal of being simple to use with as little boilerplate as possible.
- pkgver = r993.d9482c6
+ pkgver = r997.4df0260
pkgrel = 1
url = https://github.com/emil-e/rapidcheck
changelog = rapidcheck.changelog
@@ -12,8 +12,8 @@ pkgbase = rapidcheck
arch = aarch64
license = BSD
makedepends = cmake
- provides = rapidcheck=r993.d9482c6
- source = rapidcheck::git+https://github.com/emil-e/rapidcheck.git#commit=d9482c683429fe79122e3dcab14c9655874aeb8e
+ provides = rapidcheck=r997.4df0260
+ source = rapidcheck::git+https://github.com/emil-e/rapidcheck.git#commit=4df02602aae74ff1711611b64630d3fd8ae40571
md5sums = SKIP
pkgname = rapidcheck
diff --git a/PKGBUILD b/PKGBUILD
index 56845f57e5a5..d527eed9ea54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bart Verhagen <bart at verhagenconsultancy dot be>
pkgname=('rapidcheck')
pkgbase='rapidcheck'
-pkgver=r993.d9482c6
+pkgver=r997.4df0260
pkgrel=1
epoch=
pkgdesc="QuickCheck clone for C++ with the goal of being simple to use with as little boilerplate as possible."
@@ -13,14 +13,14 @@ depends=()
makedepends=(cmake)
checkdepends=()
optdepends=()
-provides=('rapidcheck=r993.d9482c6')
+provides=('rapidcheck=r997.4df0260')
conflicts=()
replaces=()
backup=()
options=()
install=
changelog=rapidcheck.changelog
-source=("rapidcheck::git+$url.git#commit=d9482c683429fe79122e3dcab14c9655874aeb8e")
+source=("rapidcheck::git+$url.git#commit=4df02602aae74ff1711611b64630d3fd8ae40571")
noextract=()
validpgpkeys=()
diff --git a/rapidcheck.changelog b/rapidcheck.changelog
index 863b5bdaf504..e1859a670b5a 100644
--- a/rapidcheck.changelog
+++ b/rapidcheck.changelog
@@ -2,7 +2,7 @@ Changelog
=========
-r993.d9482c6
+r997.4df0260
------------
Fix
@@ -17,6 +17,22 @@ Fix
Other
~~~~~
+- Merge pull request #241 from
+ hanst99/fix/missing_includes_and_signed_unsigned_comparison. [emil-e]
+
+ Add missing includes and fix signed/unsigned comparison
+- Add missing includes and fix signed/unsigned comparison. [Hannes
+ Steffenhagen]
+
+ Random was using `std::ostream` without `<iosfwd>` and `std::hash`
+ without `<functional>`. In BitStream.hpp, if `SourceType` was unsigned
+ then the comparison to `numBits` (which returns `signed int`) would
+ cause a warning (which makes the code not compile because the
+ CMakeLists.txt sets -Werror on gcc/clang).
+- Merge pull request #239 from gpyalt/master. [emil-e]
+
+ Fix some typos in generators_ref.md
+- Update generators_ref.md. [gpyalt]
- Merge pull request #237 from parbo/rtti-option. [emil-e]
Add option for using rtti